summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-12-04 14:09:32 +0100
committerUlrich Müller <ulm@gentoo.org>2014-12-04 14:09:32 +0100
commitdc971ae7801a4f66fccae8d641d85b275def6f10 (patch)
tree66bde5b6f4da4c132f285bb71f2c6bc17a8c5821
parentnet-print/brother-dcpj925dw: Fix some install locations and permission bits. (diff)
downloadulm-dc971ae7801a4f66fccae8d641d85b275def6f10.tar.gz
ulm-dc971ae7801a4f66fccae8d641d85b275def6f10.tar.bz2
ulm-dc971ae7801a4f66fccae8d641d85b275def6f10.zip
media-gfx/brscan4: Fix some install locations and permission bits.
Package-Manager: portage-2.2.14
-rw-r--r--media-gfx/brscan4/ChangeLog3
-rw-r--r--media-gfx/brscan4/brscan4-0.4.2.4.ebuild22
2 files changed, 16 insertions, 9 deletions
diff --git a/media-gfx/brscan4/ChangeLog b/media-gfx/brscan4/ChangeLog
index 8d74e7e..38785a3 100644
--- a/media-gfx/brscan4/ChangeLog
+++ b/media-gfx/brscan4/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Dec 2014; Ulrich Müller <ulm@gentoo.org> brscan4-0.4.2.4.ebuild:
+ Fix some install locations and permission bits.
+
01 Dec 2014; Ulrich Müller <ulm@gentoo.org> brscan4-0.4.2.4.ebuild:
Add configuration for sane.
diff --git a/media-gfx/brscan4/brscan4-0.4.2.4.ebuild b/media-gfx/brscan4/brscan4-0.4.2.4.ebuild
index c676d53..77c05be 100644
--- a/media-gfx/brscan4/brscan4-0.4.2.4.ebuild
+++ b/media-gfx/brscan4/brscan4-0.4.2.4.ebuild
@@ -20,24 +20,28 @@ RESTRICT="strip"
RDEPEND="media-gfx/sane-backends"
-S="${WORKDIR}"
+S="${WORKDIR}/opt/brother/scanner/${PN}"
src_install() {
local lib=$(get_libdir)
- local dest="/opt/brother/scanner/${PN}"
+ local dest=/opt/brother/scanner/${PN}
- cp -r opt "${D}" || die
+ insinto /etc${dest}
+ doins Brsane4.ini brsanenetdevice4.cfg
+ doins -r models4
+ dosym /etc${dest}/Brsane4.ini ${dest}/Brsane4.ini
+ dosym /etc${dest}/brsanenetdevice4.cfg ${dest}/brsanenetdevice4.cfg
+ dosym /etc${dest}/models4 ${dest}/models4
into ${dest}
- dolib.so usr/lib*/sane/libsane-brother4.so.1.0.7
+ dobin brsaneconfig4
+ dosym ${dest}/bin/brsaneconfig4 /usr/bin/brsaneconfig4
- dosym {../../..${dest}/${lib},/usr/${lib}/sane}/libsane-brother4.so.1.0.7
+ dolib.so "${WORKDIR}"/usr/lib*/sane/libsane-brother4.so*
+ dosym ${dest}/${lib}/libsane-brother4.so.1.0.7 \
+ /usr/${lib}/sane/libsane-brother4.so.1.0.7
dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so.1
dosym libsane-brother4.so.1.0.7 /usr/${lib}/sane/libsane-brother4.so
- dosym {../..${dest},/usr/bin}/brsaneconfig4
- dosym {../../../../..,/etc}${dest}/Brsane4.ini
- dosym {../../../../..,/etc}${dest}/brsanenetdevice4.cfg
- dosym {../../../../..,/etc}${dest}/models4
insinto /etc/sane.d/dll.d
newins - ${PN} <<< "brother4"