summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-30 10:12:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-30 10:29:51 +0200
commit0025c708d3be1ab28710cb2851dfd78ac6007ff2 (patch)
tree049547c8b81559175a4b60373760e1c93f0bcdc7
parentdev-ros/actionlib: remove old (diff)
downloadgentoo-0025c708d3be1ab28710cb2851dfd78ac6007ff2.tar.gz
gentoo-0025c708d3be1ab28710cb2851dfd78ac6007ff2.tar.bz2
gentoo-0025c708d3be1ab28710cb2851dfd78ac6007ff2.zip
dev-ros/actionlib: bump to 1.11.6
Package-Manager: portage-2.3.0
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.11.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
index 699fef578062..3d0f3b4ed4ee 100644
--- a/dev-ros/actionlib/Manifest
+++ b/dev-ros/actionlib/Manifest
@@ -1 +1,2 @@
DIST actionlib-1.11.5.tar.gz 96979 SHA256 da2b8115686db17a47bc6897b07cfec3588b3c6b8970f2d2359cfff9c41e6ccd SHA512 ba3b163c8f5547d872b789abbc6238f371a542d691fc9ae8f62ba266c3a187b9e5026bf7f0edb29f0234a01bd4d3f60edacf6118a0d3d04719c1604a49c0ce23 WHIRLPOOL 74b95cefe674f85081897a571a0d71985aa66d1a7eb3d3924d625718dac43fe3e72889813676f3dc2236d44d096ac6190a77ee6f15bccd20cd9b07b11aabc1d9
+DIST actionlib-1.11.6.tar.gz 96821 SHA256 697fb750b3494fcf28da7cc55ea8428bfd803d3faeac18f0296f1b5fa4d7920c SHA512 e3d9db3c36ded86b5f8f4f6d471a38116c1a01e6da6edbc7932b59a16d9b24ec8bbc5464e2b4e52776a066730cb73c7e2d6d6bf0c8cfe87e402c1445bc8c5302 WHIRLPOOL 14532d5694526c3466ac42f779d4d157664084bc3a52110b8da3af3a369b60dfd0cd8bde56e1ea5c39218ffe2caec0e56c95bbbd1bc3cd82af148b9437e30b3c
diff --git a/dev-ros/actionlib/actionlib-1.11.6.ebuild b/dev-ros/actionlib/actionlib-1.11.6.ebuild
new file mode 100644
index 000000000000..9959ce8fcfb7
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"