summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2019-03-19 11:27:30 -0600
committerChristoph Junghans <junghans@gentoo.org>2019-03-19 11:28:16 -0600
commit0048986412d8739500a884685acd44f241494423 (patch)
treea7b014efcb0d19304ae4d4074fe362648c67578e
parentsys-kernel/gentoo-sources: Linux patch 4.9.164 (diff)
downloadgentoo-0048986412d8739500a884685acd44f241494423.tar.gz
gentoo-0048986412d8739500a884685acd44f241494423.tar.bz2
gentoo-0048986412d8739500a884685acd44f241494423.zip
app-doc/doxygen: add xml-c++ patch
Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
-rw-r--r--app-doc/doxygen/doxygen-1.8.14-r2.ebuild134
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch25
2 files changed, 159 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.8.14-r2.ebuild b/app-doc/doxygen/doxygen-1.8.14-r2.ebuild
new file mode 100644
index 000000000000..d963510d4e41
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.8.14-r2.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit cmake-utils eutils python-any-r1
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/doxygen/doxygen.git"
+ SRC_URI=""
+else
+ SRC_URI="https://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Documentation system for most programming languages"
+HOMEPAGE="https://www.stack.nl/~dimitri/doxygen/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="clang debug doc dot doxysearch latex qt5 sqlite userland_GNU"
+
+RDEPEND="app-text/ghostscript-gpl
+ dev-lang/perl
+ media-libs/libpng:0=
+ virtual/libiconv
+ clang? ( >=sys-devel/clang-4.0.0:= )
+ dot? (
+ media-gfx/graphviz
+ media-libs/freetype
+ )
+ doxysearch? ( dev-libs/xapian:= )
+ latex? (
+ dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ )
+ qt5? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ "
+
+REQUIRED_USE="doc? ( latex )"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ doc? ( ${PYTHON_DEPS} )
+ ${RDEPEND}"
+
+# src_test() defaults to make -C testing but there is no such directory (bug #504448)
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.9.1-empty-line-sigsegv.patch" #454348
+ "${FILESDIR}/${PN}-1.8.12-link_with_pthread.patch"
+ "${FILESDIR}/${PN}-1.8.14-llvm7.patch" #666692
+ "${FILESDIR}/${PN}-1.8.14-xml-c++.patch" #doxygen/doxygen#6892
+)
+
+DOCS=( LANGUAGE.HOWTO README.md )
+
+pkg_setup() {
+ use doc && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Ensure we link to -liconv
+ if use elibc_FreeBSD && has_version dev-libs/libiconv || use elibc_uclibc; then
+ local pro
+ for pro in */*.pro.in */*/*.pro.in; do
+ echo "unix:LIBS += -liconv" >> "${pro}" || die
+ done
+ fi
+
+ # Call dot with -Teps instead of -Tps for EPS generation - bug #282150
+ sed -i -e '/addJob("ps"/ s/"ps"/"eps"/g' src/dot.cpp || die
+
+ # fix pdf doc
+ sed -i.orig -e "s:g_kowal:g kowal:" \
+ doc/maintainers.txt || die
+
+ if is-flagq "-O3" ; then
+ ewarn
+ ewarn "Compiling with -O3 is known to produce incorrectly"
+ ewarn "optimized code which breaks doxygen."
+ ewarn
+ elog
+ elog "Continuing with -O2 instead ..."
+ elog
+ replace-flags "-O3" "-O2"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Duse_libclang=$(usex clang)
+ -Dbuild_doc=$(usex doc)
+ -Dbuild_search=$(usex doxysearch)
+ -Dbuild_wizard=$(usex qt5)
+ -Duse_sqlite3=$(usex sqlite)
+ )
+ use doc && mycmakeargs+=(
+ -DDOC_INSTALL_DIR="share/doc/${P}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts" # bug #564944
+
+ if ! use dot; then
+ sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
+ {Doxyfile,doc/Doxyfile} \
+ || die "disabling dot failed"
+ fi
+ cmake-utils_src_make -C "${BUILD_DIR}" docs
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch b/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch
new file mode 100644
index 000000000000..8680d19dd46f
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch
@@ -0,0 +1,25 @@
+From f217b5c36b39a294b920437ff66055ee1a3fa5b7 Mon Sep 17 00:00:00 2001
+From: albert-github <albert.tests@gmail.com>
+Date: Tue, 19 Mar 2019 10:42:24 +0100
+Subject: [PATCH] issue #6892 xml not well-formed (invalid token) for c++
+
+the `declname` and `defname` should also be converted (compare as well the routine `generateXMLForMember`)
+---
+ src/xmlgen.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
+index 420a653fc..568e48886 100644
+--- a/src/xmlgen.cpp
++++ b/src/xmlgen.cpp
+@@ -360,8 +360,8 @@ static void writeTemplateArgumentList(ArgumentList *al,
+ }
+ if (!a->name.isEmpty())
+ {
+- t << indentStr << " <declname>" << a->name << "</declname>" << endl;
+- t << indentStr << " <defname>" << a->name << "</defname>" << endl;
++ t << indentStr << " <declname>" << convertToXML(a->name) << "</declname>" << endl;
++ t << indentStr << " <defname>" << convertToXML(a->name) << "</defname>" << endl;
+ }
+ if (!a->defval.isEmpty())
+ {