summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 22:51:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 23:42:46 +0200
commit00ee2f4bf7100b4697a48e0ebbb3d14cd1e2bf89 (patch)
tree8822ad76c36169cb51610a1970b138939031d285
parentmedia-libs/phonon: Drop 4.10.0 (diff)
downloadgentoo-00ee2f4bf7100b4697a48e0ebbb3d14cd1e2bf89.tar.gz
gentoo-00ee2f4bf7100b4697a48e0ebbb3d14cd1e2bf89.tar.bz2
gentoo-00ee2f4bf7100b4697a48e0ebbb3d14cd1e2bf89.zip
app-text/libstaroffice: 0.0.6 version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--app-text/libstaroffice/Manifest1
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.6.ebuild45
-rw-r--r--app-text/libstaroffice/libstaroffice-9999.ebuild2
3 files changed, 47 insertions, 1 deletions
diff --git a/app-text/libstaroffice/Manifest b/app-text/libstaroffice/Manifest
index 703de2c4cb98..b6a44492c05c 100644
--- a/app-text/libstaroffice/Manifest
+++ b/app-text/libstaroffice/Manifest
@@ -1 +1,2 @@
DIST libstaroffice-0.0.5.tar.xz 682380 BLAKE2B 1f514873a7dcaf210fae77f32e88ce7e3e8652474f51616865cb95ff81e7ceb86d784aab0efc301b86b416264fd0eb59c9be717039fb6a4fb086c9d09ec124ae SHA512 937fc618bef79c9e25957f25f39bc829621b0a2da0213cbfb1b56c2b00d44f61bcd9db67d3e6329a4bd700a2c88fc743088381f58a96a87712b040c0ffc17fde
+DIST libstaroffice-0.0.6.tar.xz 706324 BLAKE2B 5ff692c85bb48a7cd4c1e05e0afcc3ab26d627254dcf0b4ba10314c6ec654d69e2910f031ec7b88c9d28c48fe6a7267cd2434d224dc980ad9e266273cbc65bfa SHA512 9b5313a069e29265875f2e744b6b39c261f578d72f67fdefe1454c092aaa28399e1b3dfcb3a2f881f9a60674e0115a29350fba3ee37fb442f0a837982077f324
diff --git a/app-text/libstaroffice/libstaroffice-0.0.6.ebuild b/app-text/libstaroffice/libstaroffice-0.0.6.ebuild
new file mode 100644
index 000000000000..7578276aed40
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libstaroffice/libstaroffice-9999.ebuild b/app-text/libstaroffice/libstaroffice-9999.ebuild
index 20a958e6735b..7578276aed40 100644
--- a/app-text/libstaroffice/libstaroffice-9999.ebuild
+++ b/app-text/libstaroffice/libstaroffice-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6