summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 18:16:40 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 18:57:13 +0200
commit00f1e4557b587d73f2f79dc069b43e3243026adb (patch)
tree9059a98a94a7b79f977032e0d2089a5c214aa390
parentdev-ros/qt_gui_app: Bump to 0.4.1. (diff)
downloadgentoo-00f1e4557b587d73f2f79dc069b43e3243026adb.tar.gz
gentoo-00f1e4557b587d73f2f79dc069b43e3243026adb.tar.bz2
gentoo-00f1e4557b587d73f2f79dc069b43e3243026adb.zip
dev-ros/qt_gui_cpp: Bump to 0.4.1.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/qt_gui_cpp/Manifest1
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-0.4.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_cpp/Manifest b/dev-ros/qt_gui_cpp/Manifest
index 912a95ed0ac8..645ff8094eeb 100644
--- a/dev-ros/qt_gui_cpp/Manifest
+++ b/dev-ros/qt_gui_cpp/Manifest
@@ -1 +1,2 @@
DIST qt_gui_core-0.3.16.tar.gz 94321 BLAKE2B 87d38cfaa1ed46cdc6a08aaacef71844aec48226b6242b153d37d804e24a67300a84d7730d02f9cfcff42ab520b023b928bee6db354deec70744deb8c3136170 SHA512 44aaf7d07bc4223b1185fdfcd10f01f0eab0b2a3511dcb9cd055c98696becd07d46ceb1e15c6c78994e1069211b8c475d3b0a95523151a27e54c3f91ecc203dc
+DIST qt_gui_core-0.4.1.tar.gz 96850 BLAKE2B a8a4325d5462a0788a69661adb20b3bf1bc9e391344ced31468bf9ddbe7114a13a2ecd3dda580986bd0af98c837641bda3e3d6cd3c5d9fa3352c37817ace2ed4 SHA512 0c46f86f88a818107049d08db6682a320f47b1b4983c586e4c944a387c070c7e017fca2f4be9d251f8a907f15be439998b2d559bea51ffc724fa4afc5e75f67c
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.4.1.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.4.1.ebuild
new file mode 100644
index 000000000000..a4e1317260cc
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="C++-bindings for qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ >=dev-ros/pluginlib-1.9.23
+ dev-libs/tinyxml2:=
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)