summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Veldt <simon.vanderveldt@gmail.com>2020-08-06 21:20:15 +0200
committerSam James <sam@gentoo.org>2020-08-06 20:55:51 +0000
commit0156a2ed617b036847a2995dc3f7658fa787c114 (patch)
treec5128c8b1b6648adb6aabe07686c3f8bfc645757
parentvirtual/perl-podlators: Add Perl 5.32 version (diff)
downloadgentoo-0156a2ed617b036847a2995dc3f7658fa787c114.tar.gz
gentoo-0156a2ed617b036847a2995dc3f7658fa787c114.tar.bz2
gentoo-0156a2ed617b036847a2995dc3f7658fa787c114.zip
net-im/discord-bin: Bump to 0.0.11
Signed-off-by: Simon van der Veldt <simon.vanderveldt+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-im/discord-bin/Manifest1
-rw-r--r--net-im/discord-bin/discord-bin-0.0.11.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/net-im/discord-bin/Manifest b/net-im/discord-bin/Manifest
index 3b928a6bdd27..d582a8b9c949 100644
--- a/net-im/discord-bin/Manifest
+++ b/net-im/discord-bin/Manifest
@@ -1 +1,2 @@
DIST discord-0.0.10.deb 68310032 BLAKE2B d7b192e78ab0f7ec1ca9c2d2358d5a4a32e543507b3a7553de618af322feaf180228569489d8e14e8316234067dcbd4aaff0cb32adb60b43bbd51a321ab0b7ec SHA512 f9b901b0a8ee2b0fb70e6671231ea8fcc41b60d7499e03d29026896a96f5c2d2e3ec992b5d0db7f9ee44fefccc2c5457a76c64a643a7d51a4c9d4f994b9c5d8d
+DIST discord-0.0.11.deb 68328574 BLAKE2B 5a4bba82168056fffee2a2e495be7f5c8d8a02b890fd45645eb800a17c976db4a35719082ae469615f13ce45cadeb73ab7937ad8aac4850264275a479a8eb2c4 SHA512 26f408c3332e9083c448b3b8914fed80918a7d3ab3dd9c2a02b2cea7225ac53dea743fa899bdeeb2f210cda90493b7f35b8075a967e70d1fd6dffb1de1e8b102
diff --git a/net-im/discord-bin/discord-bin-0.0.11.ebuild b/net-im/discord-bin/discord-bin-0.0.11.ebuild
new file mode 100644
index 000000000000..b58a84dc91f3
--- /dev/null
+++ b/net-im/discord-bin/discord-bin-0.0.11.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN/-bin/}
+MY_BIN="D${MY_PN/d/}"
+
+inherit desktop pax-utils unpacker xdg-utils
+
+DESCRIPTION="All-in-one voice and text chat for gamers"
+HOMEPAGE="https://discordapp.com"
+SRC_URI="https://dl.discordapp.net/apps/linux/${PV}/${MY_PN}-${PV}.deb"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror bindist"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/libcxx
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="
+ opt/discord/${MY_BIN}
+ opt/discord/chrome-sandbox
+ opt/discord/libEGL.so
+ opt/discord/libGLESv2.so
+ opt/discord/swiftshader/libEGL.so
+ opt/discord/swiftshader/libGLESv2.so
+ opt/discord/swiftshader/libvk_swiftshader.so
+ opt/discord/libVkICD_mock_icd.so
+ opt/discord/libffmpeg.so
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s:/usr/share/discord/Discord:/opt/${MY_PN}/${MY_BIN}:g" \
+ usr/share/${MY_PN}/${MY_PN}.desktop || die
+}
+
+src_install() {
+ doicon usr/share/${MY_PN}/${MY_PN}.png
+ domenu usr/share/${MY_PN}/${MY_PN}.desktop
+
+ insinto /opt/${MY_PN}
+ doins -r usr/share/${MY_PN}/.
+ fperms +x /opt/${MY_PN}/${MY_BIN}
+ dosym ../../opt/${MY_PN}/${MY_BIN} usr/bin/${MY_PN}
+
+ pax-mark -m "${ED}"/opt/${MY_PN}/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}