summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-10-28 12:34:36 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-10-28 13:59:53 -0700
commit018330a99c4014c37161cb05b5e56cf1303e681b (patch)
tree55a63e68bb5d840580976db0ee514b300b52b455
parentdev-libs/libhid: fix typo (diff)
downloadgentoo-018330a99c4014c37161cb05b5e56cf1303e681b.tar.gz
gentoo-018330a99c4014c37161cb05b5e56cf1303e681b.tar.bz2
gentoo-018330a99c4014c37161cb05b5e56cf1303e681b.zip
net-dns/dnscrypt-proxy: bump to 2.0.29
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--net-dns/dnscrypt-proxy/Manifest1
-rw-r--r--net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.29.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/net-dns/dnscrypt-proxy/Manifest b/net-dns/dnscrypt-proxy/Manifest
index 5a32cd314819..af2a2a0c3662 100644
--- a/net-dns/dnscrypt-proxy/Manifest
+++ b/net-dns/dnscrypt-proxy/Manifest
@@ -2,3 +2,4 @@ DIST dnscrypt-proxy-2.0.19.tar.gz 3339713 BLAKE2B e65b5ed8243aa6cf471700c6edba6e
DIST dnscrypt-proxy-2.0.25.tar.gz 2596674 BLAKE2B 10947c9e496c47a565e62fb4ca6ad95679da0d237885fe09da367b501bf0dd228cb3d4af41b3527dca64665364527ec2db06afab2c209792409078debd7d3fc8 SHA512 74a47b013e15cbdcf8691bf3618cce40149f9832f6fc4c2cbfb6af2a72b4ecb52b068a150999771a77fcf4fdb49c64dabd127c5101ae29fb86723bc30c946133
DIST dnscrypt-proxy-2.0.27.tar.gz 2478887 BLAKE2B e9cabd6bdb330c3174cb904951f9e1a0a5482b642d458dd9fc7cba8d05333e7d91c37d43fbd360d8fbcda1c5febd2e5d577e0e612d9c2211047ba2a047b929ef SHA512 68cecec0228b3f03d5c50576c7dec32c7474a22bd1740d43b29514b5a00f27376ed5236302fa68c493f0c188134855b277fbbbb922222937fa726783af3f7246
DIST dnscrypt-proxy-2.0.28.tar.gz 2620245 BLAKE2B fe31dd6d8054c4ae3d5892aaef0c8362405e06dba6de32121d9dea5d64d396ec39b1cfa884d5587c21367bb1dc3c1a4b4f994c286d0b8cc2a8bdbd9d247d239e SHA512 45496a02bd19c94def17b621d0843cc93de4467e51ded4c20af91d9b5aa127529d85b8ff2473a88293c726611291a055d466a50258b7587da0e7d4ba7f0f366e
+DIST dnscrypt-proxy-2.0.29.tar.gz 2621844 BLAKE2B 3ebd02b3c9df9dcb41d27d38a9d9f64c01d98f7b1afee7a7c3b1dd3ef26b2104aae650e34ff1b5651007461ee75d28bcfbfa3c7e82c32532f36553740e3dcb50 SHA512 f02abe56e017153e7fc8b4a26b34c90f68554a1b32a16558c05e8113327896dbf7f81aa69c76fa823a4a0a697b4bb2089bdeb1237ad4ef3587121c2d4cdfe78c
diff --git a/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.29.ebuild b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.29.ebuild
new file mode 100644
index 000000000000..c2e5ddb01ed9
--- /dev/null
+++ b/net-dns/dnscrypt-proxy/dnscrypt-proxy-2.0.29.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/jedisct1/${PN}"
+
+inherit fcaps golang-build systemd
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+else
+ SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+fi
+
+DESCRIPTION="A flexible DNS proxy, with support for encrypted DNS protocols"
+HOMEPAGE="https://github.com/jedisct1/dnscrypt-proxy"
+
+LICENSE="Apache-2.0 BSD ISC MIT MPL-2.0"
+SLOT="0"
+IUSE="pie"
+
+DEPEND=">=dev-lang/go-1.12"
+
+RDEPEND="
+ acct-group/dnscrypt-proxy
+ acct-user/dnscrypt-proxy
+"
+
+FILECAPS=( cap_net_bind_service+ep usr/bin/dnscrypt-proxy )
+PATCHES=( "${FILESDIR}"/config-full-paths-r10.patch )
+
+src_prepare() {
+ default
+ # Create directory structure suitable for building
+ mkdir -p "src/${EGO_PN%/*}" || die
+ # fixes $GOPATH/go.mod exists but should not
+ rm go.mod || die
+ mv "${PN}" "src/${EGO_PN}" || die
+ mv "vendor" "src/${EGO_PN}" || die
+}
+
+src_configure() {
+ EGO_BUILD_FLAGS="-buildmode=$(usex pie pie default)"
+}
+
+src_install() {
+ dobin dnscrypt-proxy
+
+ insinto /etc/dnscrypt-proxy
+ newins "src/${EGO_PN}"/example-dnscrypt-proxy.toml dnscrypt-proxy.toml
+ doins "src/${EGO_PN}"/example-{blacklist.txt,whitelist.txt}
+ doins "src/${EGO_PN}"/example-{cloaking-rules.txt,forwarding-rules.txt}
+
+ insinto /usr/share/dnscrypt-proxy
+ doins -r "utils/generate-domains-blacklists/."
+
+ newinitd "${FILESDIR}"/dnscrypt-proxy.initd dnscrypt-proxy
+ newconfd "${FILESDIR}"/dnscrypt-proxy.confd dnscrypt-proxy
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.service dnscrypt-proxy.service
+ systemd_newunit "${FILESDIR}"/dnscrypt-proxy.socket dnscrypt-proxy.socket
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/dnscrypt-proxy.logrotate dnscrypt-proxy
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ fcaps_pkg_postinst
+
+ if ! use filecaps; then
+ ewarn "'filecaps' USE flag is disabled"
+ ewarn "${PN} will fail to listen on port 53"
+ ewarn "please do one the following:"
+ ewarn "1) re-enable 'filecaps'"
+ ewarn "2) change port to > 1024"
+ ewarn "3) configure to run ${PN} as root (not recommended)"
+ ewarn
+ fi
+
+ if systemd_is_booted || has_version sys-apps/systemd; then
+ elog "Using systemd socket activation may cause issues with speed"
+ elog "latency and reliability of ${PN} and is discouraged by upstream"
+ elog "Existing installations advised to disable 'dnscrypt-proxy.socket'"
+ elog "It is disabled by default for new installations"
+ elog "check "$(systemd_get_systemunitdir)/${PN}.service" for details"
+ elog
+
+ fi
+
+ elog "After starting the service you will need to update your"
+ elog "/etc/resolv.conf and replace your current set of resolvers"
+ elog "with:"
+ elog
+ elog "nameserver 127.0.0.1"
+ elog
+ elog "Also see https://github.com/jedisct1/${PN}/wiki"
+}