summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-06-27 11:52:37 +0200
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-06-27 09:57:56 -0700
commit01b42754f9116fbf009eed9cf845595d3d8a5a4a (patch)
tree922d7a96c3561f91235136ce82c2f050d5c3f516
parentdev-libs/appstream-glib: bump to 0.7.9 (diff)
downloadgentoo-01b42754f9116fbf009eed9cf845595d3d8a5a4a.tar.gz
gentoo-01b42754f9116fbf009eed9cf845595d3d8a5a4a.tar.bz2
gentoo-01b42754f9116fbf009eed9cf845595d3d8a5a4a.zip
app-emulation/vagrant: bump to 2.1.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-emulation/vagrant/Manifest1
-rw-r--r--app-emulation/vagrant/vagrant-2.1.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index e9dc30b7d405..cf6a0e38e94a 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,3 +1,4 @@
DIST vagrant-2.0.2.tar.gz 1177773 BLAKE2B 7624ce0bbc5f606bff89a0ef7d9d562f5caeea50b2b13744aef5e037f0b7861ccd2b6450f1686f4285027540b795539ef548ddadaf2f6c1476c87717078ebc7f SHA512 27e8157cf8a8d102a0ca328403410639bd4a9f7cb90d443f5be3ca912aeb6177208b26ba9751b49d98b5ba1e92f8bec74db0baca4cd22051d5ef6d3aca558f3a
DIST vagrant-2.0.3.tar.gz 1181697 BLAKE2B fa33063b52e6b9c9a1212a8833ee70c1d45dc4d09f039882337e2571bac5fcb2c5cf5199c7a39ea539873cc445ec768946a12c0a8bb7b03f51e133d56388bf15 SHA512 c62366c2e2b190a19efeae3379573c9e534b296db68152f284f3d80e9fdff4260e246c40206076e222bda3cf8f4ecbd02656c65aa35c15606b8638d7a8fca200
DIST vagrant-2.1.1.tar.gz 1204711 BLAKE2B 88a6254091104eed702e07a4203a264b883869fb028b8d30fd51ddfc2053aec363683a2e73d1454ce92b705440920d5c80c0f967e4dc110bf425ce17973efccd SHA512 6cc82b4c33b196fce2bc460447afd152e53c3c17b45db5d80958ff631f6747c386b625ff26e3d8830a88b2feca82d550ad1de32e7c7607dffb25960af43092f5
+DIST vagrant-2.1.2.tar.gz 1218801 BLAKE2B 742f27ca6c28c9738c09ef61c742be07121b5a804fa401115520633e5840c62c8e879fae078c5532704f6f6f7d7a9081d48e3f7570cfe6e6dd84f8df244a34ae SHA512 d9a2612697842885d23d1a9a452ef9d8b03defa4e6f7a808725ac7c3a87300affcfdd89ee3a42334259601e19f1e56bfd86a5aa7b404eac26bc22dcfd4a57751
diff --git a/app-emulation/vagrant/vagrant-2.1.2.ebuild b/app-emulation/vagrant/vagrant-2.1.2.ebuild
new file mode 100644
index 000000000000..5778c6f947c5
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit bash-completion-r1 ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+virtualbox"
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ virtualbox? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.6.0
+ >=dev-ruby/erubis-2.7.0
+ <dev-ruby/i18n-0.8.0:*
+ >=dev-ruby/listen-3.1.5
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/log4r-1.1.9 <dev-ruby/log4r-1.1.11
+ >=dev-ruby/net-ssh-4.2.0:*
+ >=dev-ruby/net-sftp-2.1
+ >=dev-ruby/net-scp-1.2.0
+ || ( dev-ruby/rest-client:2 >=dev-ruby/rest-client-1.6.0:0 )
+ >=dev-ruby/nokogiri-1.7.1
+ <dev-ruby/mime-types-3:*
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-12.0.0
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/hashicorp-checkpoint\|listen\|net-ssh\|net-scp\|rake\|childprocess/s/~>/>=/' \
+ -e '/ruby_dep/s/<=/>=/' \
+ -i ${PN}.gemspec || die
+
+ # remove windows-specific gems
+ sed -e '/wdm\|win32-\|winrm/d' \
+ -i ${PN}.gemspec || die
+
+ # remove bsd-specific gems
+ sed -e '/rb-kqueue/d' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in-r1" > "${PN}" || die
+}
+
+all_ruby_install() {
+ newbashcomp contrib/bash/completion.sh ${PN}
+ all_fakegem_install
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+}