summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2018-01-11 15:13:35 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-01-22 22:57:55 +0100
commit0317dcdcfd1915153eb7c9d043ff43cd32dc54cb (patch)
treeb33313aa7930dbe3a1d0fddf2574f8bb76a36e96
parentnet-dns/bind-tools: add amd64-fbsd keyword. (diff)
downloadgentoo-0317dcdcfd1915153eb7c9d043ff43cd32dc54cb.tar.gz
gentoo-0317dcdcfd1915153eb7c9d043ff43cd32dc54cb.tar.bz2
gentoo-0317dcdcfd1915153eb7c9d043ff43cd32dc54cb.zip
sci-mathematics/gimps: version bump to 29.4 build 7.
Closes: https://bugs.gentoo.org/644194 Closes: https://github.com/gentoo/gentoo/pull/6831
-rw-r--r--sci-mathematics/gimps/Manifest2
-rw-r--r--sci-mathematics/gimps/gimps-29.4.7.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-mathematics/gimps/Manifest b/sci-mathematics/gimps/Manifest
index 61c15251cb46..38024671cd62 100644
--- a/sci-mathematics/gimps/Manifest
+++ b/sci-mathematics/gimps/Manifest
@@ -2,3 +2,5 @@ DIST p95v2810.linux32.tar.gz 4610763 BLAKE2B a6c811235644cdc4d359406504051965b58
DIST p95v2810.linux64.tar.gz 5707219 BLAKE2B 1ad26aa2fba4d7f4727bcd2dfe010d2b5b780e7516f7794111f7d5a782bb5d00080de3e87b98f110ca15a61c128ee18472c2655aaa68cb5498eb5bda11a06a4d SHA512 c4fd692df3018e5e73ba6095de5ed394f36d5c89dd81c2c7f2c74a4ce3184b22176dc13b8b59e4f42c1781e911107dc12224cfcddef882535931319ec93120f1
DIST p95v294b5.linux32.tar.gz 5455113 BLAKE2B a615ff15a77eaeebd6a1324f59e6b780d88785952d2517c5ed088f16be74e33e75e98d971eefdce10d17ad0237672cde8111e7b3205d93a4b81bbb949f0d662c SHA512 e8a0061c363333a7c36eb24ef72e9293903404563d04cdcad6432e63d25d8b85e1f0c8e8a46d9795a204830a01031024f82362bcedec4fcec954899e4d6e7127
DIST p95v294b5.linux64.tar.gz 6244650 BLAKE2B c81623f70c66ec9443c1f4858851525b9064bcfd948bb831f63774e6a09ee2e86eb2e295db4d849ac40e55f1d5166a470e248b5eac0a4b2a4322b7041f1032a9 SHA512 e315ea226649df2135895a1206e5845fd05587ad190b676228e5e1cfca04a11b698f1a7d5b8e7c96b0cd174ce3dbeb6000240b67a3f0f90572f3bf15166020e5
+DIST p95v294b7.linux32.tar.gz 5455201 BLAKE2B 2d542c06fb490f6619884be3cd510fb77e130184d2b7d3bb44fd375fcd7c95e38ef4cf80ed01079c9f395d6e8a526930a07357f20e14277beba4e232f4e2ca27 SHA512 21ee6a8f0a4482bdb22d80093b24a8b9d7e091577628dc797ad01d3a0ab98e946814c70a6313e2624fffa6658454707f88d24608e107048fc6361d15aa5a7fbe
+DIST p95v294b7.linux64.tar.gz 6244730 BLAKE2B ca5d0aad96e9bd5fb1bcb232435a26b7d8c2b9d869a6dc638d883fb892013df7a823abb0dae4545c2191b5f39b9cd29ee83400f452fbe63255f2dca899ad6bce SHA512 0579ea9ca1977884c8c50f8c8655b0fef1d5e2b456adca23d6d93542734727f265dc8f784c27fc9510c89afeec7386d4a9a9e9b5d691a97fed8189bef5577b3d
diff --git a/sci-mathematics/gimps/gimps-29.4.7.ebuild b/sci-mathematics/gimps/gimps-29.4.7.ebuild
new file mode 100644
index 000000000000..09dcabd77d11
--- /dev/null
+++ b/sci-mathematics/gimps/gimps-29.4.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pax-utils systemd readme.gentoo-r1 versionator
+
+DESCRIPTION="The Great Internet Mersenne Prime Search"
+HOMEPAGE="http://mersenne.org/"
+
+# The author has finally caved in to the pressure of putting the build
+# number in the package name. Some dark magic necessary to get to the
+# package name
+
+MY_PV=$(replace_version_separator 2 'b' )
+
+SRC_URI="
+ amd64? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux64.tar.gz )
+ x86? ( ftp://mersenne.org/gimps/p95v${MY_PV/./}.linux32.tar.gz )"
+
+SLOT="0"
+LICENSE="GIMPS"
+KEYWORDS="-* ~amd64 ~x86"
+
+# Since there are no statically linked binaries for this version of mprime,
+# and no static binaries for amd64 in general, we use the dynamically linked
+# ones and try to cover the .so deps with the packages listed in RDEPEND.
+# libgmp.so.10.3.2 is bundled within the .tar.gz, but we use the system one.
+
+DEPEND=""
+RDEPEND="net-misc/curl
+ >=dev-libs/gmp-6.1.2"
+
+S="${WORKDIR}"
+I="/opt/gimps"
+
+QA_PREBUILT="opt/gimps/mprime"
+
+DOCS=( license.txt readme.txt stress.txt whatsnew.txt undoc.txt )
+
+src_install() {
+ dodir ${I} /var/lib/gimps
+ pax-mark m mprime
+ cp mprime "${D}/${I}" || die
+ fperms a-w "${I}/mprime"
+ fowners root:0 "${I}"
+ fowners root:0 "${I}/mprime"
+
+ einstalldocs
+
+ readme.gentoo_create_doc
+
+ newinitd "${FILESDIR}/${PN}-28.9-init.d" gimps
+ newconfd "${FILESDIR}/${PN}-25.6-conf.d" gimps
+
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}.conf"
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ echo
+ einfo "GIMPS data files were not removed."
+ einfo "Remove them manually from /var/lib/gimps/"
+ echo
+}