summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 14:42:11 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 14:43:43 -0700
commit0350f6eb22ba3371d548219c65d65da51d110da6 (patch)
tree6881233e4ed39c7a9282795b1f22c493710762b6
parentdev-ml/camlpdf: drop myself as a maintainer (diff)
downloadgentoo-0350f6eb22ba3371d548219c65d65da51d110da6.tar.gz
gentoo-0350f6eb22ba3371d548219c65d65da51d110da6.tar.bz2
gentoo-0350f6eb22ba3371d548219c65d65da51d110da6.zip
app-text/cpdf: version bump to 2.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
-rw-r--r--app-text/cpdf/Manifest1
-rw-r--r--app-text/cpdf/cpdf-2.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/cpdf/Manifest b/app-text/cpdf/Manifest
index e8e2f5b13de3..f4180f33fe84 100644
--- a/app-text/cpdf/Manifest
+++ b/app-text/cpdf/Manifest
@@ -1 +1,2 @@
DIST cpdf-2.2.1.tar.gz 704730 BLAKE2B 1767d2c9fdc645b4ff97b828b1d7bedb22aa645444f299e36ec4717015ea7b87dbbac4c9ec27bb508a7adb28b2c75c155bf9094a168567abbffa93887712241d SHA512 3dda72513c551cca5d8cb60732b3f2c2e8ad400bd2c9fcf0c3b54a68e94385e3f19ec7713de95efa90eafb7b0077662097565a28616041019e03edf140b6af4f
+DIST cpdf-2.3.tar.gz 384594 BLAKE2B 391cc2d88ae5ad2decc3911ea2125345cb337e15f059b2411f8e835f91460bc0cb28410ebe8a15bbf3c2c5ba511f89b0bcfec8ccae3aca69658fd6eb55c64dc2 SHA512 db17bd019a6c2a719761662af682cc74a7dbcc673c22867652cef37508b6d3dcbf4d5da9d9db9e8b1b0cf912f03be18f16748ab15dcbdfbdfd37900d4fd04ddd
diff --git a/app-text/cpdf/cpdf-2.3.ebuild b/app-text/cpdf/cpdf-2.3.ebuild
new file mode 100644
index 000000000000..3df1825ad110
--- /dev/null
+++ b/app-text/cpdf/cpdf-2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A command line tool for manipulating PDF files"
+HOMEPAGE="https://community.coherentpdf.com/ https://github.com/johnwhitington/cpdf-source/"
+SRC_URI="https://github.com/johnwhitington/cpdf-source/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# BSD is only for xmlm.ml
+LICENSE="Coherent-Graphics BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/ocaml-4:=[ocamlopt]
+ ~dev-ml/camlpdf-${PV}:="
+DEPEND="${RDEPEND}"
+
+RESTRICT="mirror bindist"
+
+S=${WORKDIR}/${PN}-source-${PV}
+
+src_compile() {
+ # parallel make issues
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+
+ dobin cpdf
+ dodoc Changes README.md cpdfmanual.pdf
+ doman cpdf.1
+
+ use doc && dodoc -r doc/cpdf/html
+}