summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-05-28 21:27:13 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-01 19:06:47 +0200
commit03a0d2020c546f79f4079edb1c367f3a42dcc01b (patch)
treec1ac4aa61fdee0130cd27fb0483156d17b9c1c87
parentdev-python/tappy: add py3.10 (diff)
downloadgentoo-03a0d2020c546f79f4079edb1c367f3a42dcc01b.tar.gz
gentoo-03a0d2020c546f79f4079edb1c367f3a42dcc01b.tar.bz2
gentoo-03a0d2020c546f79f4079edb1c367f3a42dcc01b.zip
dev-python/dbus-python: add py3.10
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
index 2a6f8bd59269..dc7eb8eeea93 100644
--- a/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.2.16-r1.ebuild
@@ -3,13 +3,13 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -28,7 +28,10 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep 'dev-python/sphinx[${PYTHON_USEDEP}]') )
+ doc? ( $(python_gen_any_dep '
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ ') )
test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/tappy[${PYTHON_USEDEP}] )
"
@@ -37,6 +40,7 @@ PATCHES=( "${FILESDIR}/${P}-py39.patch" )
python_check_deps() {
has_version "dev-python/sphinx[${PYTHON_USEDEP}]"
+ has_version "dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]"
}
src_prepare() {