summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2018-06-09 09:39:51 +0200
committerNicolas Bock <nicolasbock@gentoo.org>2018-06-09 09:40:57 +0200
commit03d128168742d628a45ac39c364abc7a8d88d3df (patch)
tree3f419008f97deb9875e083d193fa5ef6ba6ae397
parentkde-frameworks/ktexteditor: Fix CVE-2018-10361 (diff)
downloadgentoo-03d128168742d628a45ac39c364abc7a8d88d3df.tar.gz
gentoo-03d128168742d628a45ac39c364abc7a8d88d3df.tar.bz2
gentoo-03d128168742d628a45ac39c364abc7a8d88d3df.zip
app-crypt/kbfs: Add kbfs systemd service
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-crypt/kbfs/kbfs-1.0.44-r1.ebuild50
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild10
2 files changed, 54 insertions, 6 deletions
diff --git a/app-crypt/kbfs/kbfs-1.0.44-r1.ebuild b/app-crypt/kbfs/kbfs-1.0.44-r1.ebuild
new file mode 100644
index 000000000000..7d419c6fd750
--- /dev/null
+++ b/app-crypt/kbfs/kbfs-1.0.44-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="Keybase Filesystem (KBFS)"
+HOMEPAGE="https://keybase.io/docs/kbfs"
+SRC_URI="https://github.com/keybase/kbfs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="git"
+
+DEPEND=">=dev-lang/go-1.6:0"
+RDEPEND="
+ app-crypt/gnupg
+ sys-fs/fuse
+ "
+
+S="${WORKDIR}/src/github.com/keybase/kbfs"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ mkdir -p "$(dirname "${S}")" || die
+ mv "kbfs-${PV}" "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/kbfsfuse" \
+ github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
+}
+
+src_install() {
+ dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
+}
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
index b084faeb8f15..e3870b505ace 100644
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit git-r3
+inherit git-r3 systemd
DESCRIPTION="Keybase Filesystem (KBFS)"
HOMEPAGE="https://keybase.io/docs/kbfs"
@@ -14,10 +14,7 @@ SLOT="0"
KEYWORDS=""
IUSE="git"
-DEPEND="
- >=dev-lang/go-1.6:0
- >=app-crypt/keybase-1.0.17
- "
+DEPEND=">=dev-lang/go-1.6:0"
RDEPEND="
app-crypt/gnupg
sys-fs/fuse
@@ -49,4 +46,5 @@ src_install() {
dobin "${T}/kbfsfuse"
use git && \
dobin "${T}/git-remote-keybase"
+ systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
}