summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2019-06-27 10:16:18 +0300
committerEray Aslan <eras@gentoo.org>2019-06-27 10:16:18 +0300
commit048a63342e6281fc052df6a411cf3c70703e123b (patch)
tree4f7e287d24b2ce8da1f5f6e58a27b0a36b44ced5
parentdev-python/pytest-xdist: keyworded 1.28.0 for ia64, bug #687200 (diff)
downloadgentoo-048a63342e6281fc052df6a411cf3c70703e123b.tar.gz
gentoo-048a63342e6281fc052df6a411cf3c70703e123b.tar.bz2
gentoo-048a63342e6281fc052df6a411cf3c70703e123b.zip
net-mail/mailutils: bump to 3.7
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Eray Aslan <eras@gentoo.org>
-rw-r--r--net-mail/mailutils/Manifest1
-rw-r--r--net-mail/mailutils/mailutils-3.7.ebuild134
2 files changed, 135 insertions, 0 deletions
diff --git a/net-mail/mailutils/Manifest b/net-mail/mailutils/Manifest
index 726cd73f5438..22a6799b2dc1 100644
--- a/net-mail/mailutils/Manifest
+++ b/net-mail/mailutils/Manifest
@@ -1,3 +1,4 @@
DIST mailutils-3.4.tar.xz 2619672 BLAKE2B 3a49c319a7171b2659477e6892ae222a342243e84ed2ee93e6d77353e1871d57d101a3a6ee3d2442709adbfb090e4931e134369661e8e8aa407061c1eccdf862 SHA512 548d97a4a036ef0ef5a429c82ffa43dd377b210b4c4d3844e7e5dded0f963060e3733b7766821c06ccf4dc1135002608658bcd6420e75b4ca1f4f17cfc8e2573
DIST mailutils-3.5.tar.xz 2742824 BLAKE2B ca14597114203234912cf4cfaa4c63e682561deb28d9d0825373c69de267c215d12b9db662cfd60024228e119433fb40a136d65cfd04385f881ba4b0384c8328 SHA512 6aa2de352be637295a8ab53207a8065f5c10655acc299ac0a2190937ec4decb515ac1044c9a7465b08764ca45be569012cce1046b40d748f6e4f31644f056a53
DIST mailutils-3.6.tar.xz 2813412 BLAKE2B fa2cde98287f84745c1ccc213d2ee824857b9c64d493677ed817ae53d49576382d22784ad25faa644ca43528637ed629aa4e9a78a3b1040fd51658e54b369399 SHA512 f07b8dc570abf345d45439f4994173d2415f94d72291aac46528842e339aaa7925baf776ccfc8f8901cf0e08a13cbfdf09596dd6c448bf012af002ef5ce2fe0e
+DIST mailutils-3.7.tar.xz 2846864 BLAKE2B d407d370a4823972c060ea6c6a6e16eefe46598fee8302159f9d44fe150ace32b6915e7e3d4ddaca63ed5d5a5cffce48514f7f6297413a97692eb609a295622d SHA512 aa93ee1cde76392808f492dae6c69625ab124a2c31a296449ba217fc26f292871b4d04f8720bf20377177eab33c01cbfe195d6ac3674c35e1db53157a6916a4d
diff --git a/net-mail/mailutils/mailutils-3.7.ebuild b/net-mail/mailutils/mailutils-3.7.ebuild
new file mode 100644
index 000000000000..9a796c2d5cd8
--- /dev/null
+++ b/net-mail/mailutils/mailutils-3.7.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit autotools elisp-common eutils flag-o-matic python-single-r1 toolchain-funcs
+
+DESCRIPTION="A useful collection of mail servers, clients, and filters"
+HOMEPAGE="https://www.gnu.org/software/mailutils/mailutils.html"
+SRC_URI="mirror://gnu/mailutils/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="berkdb bidi +clients emacs gdbm sasl guile ipv6 kerberos kyotocabinet \
+ ldap mysql nls pam postgres python servers ssl static-libs +threads tcpd \
+ tokyocabinet"
+
+RDEPEND="!mail-client/nmh
+ !mail-filter/libsieve
+ !mail-client/mailx
+ !mail-client/nail
+ sys-libs/ncurses:=
+ sys-libs/readline:=
+ dev-libs/libltdl:0
+ virtual/mta
+ berkdb? ( sys-libs/db:= )
+ bidi? ( dev-libs/fribidi )
+ emacs? ( virtual/emacs )
+ gdbm? ( sys-libs/gdbm )
+ guile? ( dev-scheme/guile:12/2.2-1 )
+ kerberos? ( virtual/krb5 )
+ kyotocabinet? ( dev-db/kyotocabinet )
+ ldap? ( net-nds/openldap )
+ mysql? ( dev-db/mysql-connector-c )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql:= )
+ python? ( ${PYTHON_DEPS} )
+ sasl? ( virtual/gsasl )
+ servers? ( virtual/libiconv dev-libs/libunistring )
+ ssl? ( net-libs/gnutls:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+ tokyocabinet? ( dev-db/tokyocabinet )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ servers? ( tcpd ldap )"
+
+DOCS=( ABOUT-NLS AUTHORS COPYING COPYING.LESSER ChangeLog INSTALL NEWS README THANKS TODO )
+PATCHES=( "${FILESDIR}/${PN}-3.5-add-include.patch" \
+ "${FILESDIR}/${PN}-3.6-underlinking.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ if use mysql; then
+ sed -i -e /^INCLUDES/"s:$:$(mysql_config --include):" \
+ sql/Makefile.am || die
+ fi
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # maildir is the Gentoo default
+ econf MU_DEFAULT_SCHEME=maildir \
+ CURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+ $(use_with berkdb berkeley-db) \
+ $(use_with bidi fribidi) \
+ $(use_enable ipv6) \
+ $(use_with gdbm) \
+ $(use_with sasl gsasl) \
+ $(use_with guile) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with postgres) \
+ $(use_enable python) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread) \
+ $(use_with tokyocabinet) \
+ $(use_with kyotocabinet) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_enable servers build-servers) \
+ $(use_with servers unistring ) \
+ $(use_enable clients build-clients) \
+ EMACS=$(usex emacs emacs no) \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-mail-spool=/var/spool/mail \
+ --with-readline \
+ --enable-sendmail \
+ --disable-debug
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ # bug 613112
+ newins "${FILESDIR}/mailutils.rc" mailutils.conf
+ keepdir /etc/mailutils.d/
+ insinto /etc/mailutils.d
+ doins "${FILESDIR}/mail"
+
+ if use python; then
+ python_optimize
+ if use static-libs; then
+ rm -r "${D}$(python_get_sitedir)/mailutils"/*.{a,la} || die
+ fi
+ fi
+
+ if use servers; then
+ newinitd "${FILESDIR}"/imap4d.initd imap4d
+ newinitd "${FILESDIR}"/pop3d.initd pop3d
+ newinitd "${FILESDIR}"/comsatd.initd comsatd
+ fi
+
+ # compatibility link
+ use clients && dosym /usr/bin/mail /bin/mail
+
+ use static-libs || find "${D}" -name "*.la" -delete
+}