summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2016-07-29 16:35:17 -0400
committerZero_Chaos <zerochaos@gentoo.org>2016-07-29 16:39:31 -0400
commit057c15f1bdb496f1f21704c8bd46181490a14532 (patch)
tree61911d98df0abd20e678ca7404541263894d31e9
parentdev-ruby/rex-powershell: initial ebuild, dep for metasploit (diff)
downloadgentoo-057c15f1bdb496f1f21704c8bd46181490a14532.tar.gz
gentoo-057c15f1bdb496f1f21704c8bd46181490a14532.tar.bz2
gentoo-057c15f1bdb496f1f21704c8bd46181490a14532.zip
dev-ruby/rex-zip: initial ebuild, dep of metasploit
Package-Manager: portage-2.3.0
-rw-r--r--dev-ruby/rex-zip/Manifest1
-rw-r--r--dev-ruby/rex-zip/metadata.xml13
-rw-r--r--dev-ruby/rex-zip/rex-zip-0.1.0.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/rex-zip/Manifest b/dev-ruby/rex-zip/Manifest
new file mode 100644
index 000000000000..0d17b72deae1
--- /dev/null
+++ b/dev-ruby/rex-zip/Manifest
@@ -0,0 +1 @@
+DIST rex-zip-0.1.0.gem 23040 SHA256 b3baa908fd912a3b0366f92247b9e9391c265fdb9456ac3864dc635176588647 SHA512 402c16a814b497cf920b9d9637c77066dc30bbc5807e84edb939e8cbc034e5554a49e94ef86f93169872a4679e8118e785e037f5e820eae02c5921763947918a WHIRLPOOL 74552a04c62d497dba7d1803968fb8a725193bd46a20bba8cc150da009b17db23bd4e774e2e92faf336d4ddb39d6b92188afd93a57a66aa2d0e0817bfbb7c289
diff --git a/dev-ruby/rex-zip/metadata.xml b/dev-ruby/rex-zip/metadata.xml
new file mode 100644
index 000000000000..180da3d7e3b1
--- /dev/null
+++ b/dev-ruby/rex-zip/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">rapid7/rex-zip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rex-zip/rex-zip-0.1.0.ebuild b/dev-ruby/rex-zip/rex-zip-0.1.0.ebuild
new file mode 100644
index 000000000000..3639eeb820ea
--- /dev/null
+++ b/dev-ruby/rex-zip/rex-zip-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+#RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby Exploitation(Rex) library for working with zip and related files"
+HOMEPAGE="https://rubygems.org/gems/rex-zip"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+# doesn't seem to actually run any tests
+RESTRICT=test
+
+ruby_add_bdepend "dev-ruby/rex-text"
+
+all_ruby_install() {
+ ruby_fakegem_binwrapper console ${PN}-console
+ ruby_fakegem_binwrapper setup ${PN}-setup
+}