summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-08-07 12:09:13 +1000
committerSam James <sam@gentoo.org>2022-08-10 04:34:46 +0100
commit069e8497134164fba8ab4d729c77643a87588c0c (patch)
treeb880414bee4ebf410387aef0f72f66363580caa7
parentdev-haskell/semigroupoids: refresh metadata.xml (diff)
downloadgentoo-069e8497134164fba8ab4d729c77643a87588c0c.tar.gz
gentoo-069e8497134164fba8ab4d729c77643a87588c0c.tar.bz2
gentoo-069e8497134164fba8ab4d729c77643a87588c0c.zip
dev-haskell/tls: add 1.5.8
Bug: https://bugs.gentoo.org/863191 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/tls/Manifest1
-rw-r--r--dev-haskell/tls/tls-1.5.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/tls/Manifest b/dev-haskell/tls/Manifest
index e066554e23c6..43ac255229dd 100644
--- a/dev-haskell/tls/Manifest
+++ b/dev-haskell/tls/Manifest
@@ -1 +1,2 @@
DIST tls-1.5.4.tar.gz 150171 BLAKE2B 03085bd5f0d20b27fd5ea31e5e6179a15ac5893cc585d5a274523444838e8e05e9f3f4028b44147d6bb20df2c37e293046255765c253b57d2be4584066f24f8b SHA512 fb95ab6012ed95d82a41810b83e6f779645fa56d46c57f34a954a6885c295737808edcdcdca9e88e5b3c663f5aee71f104fe1fdd9ab35fb6a8ade4a202376d4a
+DIST tls-1.5.8.tar.gz 157923 BLAKE2B b6b1259f6950e15fcba584690f59fd66a1a597490cbcb76e7199c48677f0df00e86f27f12e0c02210ba83cac110346aec6e7afb460f7e9721f275d146040cac5 SHA512 81d0046aeb6342c5dcd3827d9315793b68436a4eec7c9bcae50f4b5b5365248c7c874addca77a50a19689f535386330435b5914386306a3f12d699a5fad1107a
diff --git a/dev-haskell/tls/tls-1.5.8.ebuild b/dev-haskell/tls/tls-1.5.8.ebuild
new file mode 100644
index 000000000000..e020a9f1e3e6
--- /dev/null
+++ b/dev-haskell/tls/tls-1.5.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: -hans
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="https://github.com/vincenthz/hs-tls"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+compat +network"
+
+RDEPEND="dev-haskell/asn1-encoding:=[profile?]
+ >=dev-haskell/asn1-types-0.2.0:=[profile?]
+ >=dev-haskell/async-2.0:=[profile?]
+ >=dev-haskell/cereal-0.5.3:=[profile?]
+ >=dev-haskell/cryptonite-0.27:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/hourglass:=[profile?]
+ >=dev-haskell/memory-0.14.6:=[profile?]
+ >=dev-haskell/x509-1.7.5:=[profile?]
+ >=dev-haskell/x509-store-1.6:=[profile?]
+ >=dev-haskell/x509-validation-1.6.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ network? ( >=dev-haskell/network-2.4.0.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-quickcheck )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat) \
+ --flag=-hans \
+ $(cabal_flag network network)
+}