summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-28 18:28:22 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-29 11:53:08 -0800
commit06a54d7f4d312eb44ca519cb895643d8e5b7c712 (patch)
tree8e0bdca2c5bfad000f8f59c2ca0a3e59efe66eed
parentdev-python/wrapt-1.11.2-r1: Revbump, add py38, use new eclass funcs (diff)
downloadgentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.tar.gz
gentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.tar.bz2
gentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.zip
dev-python/reno-2.11.3: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-2.11.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 60b1aef19246..c185cace0799 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1,2 +1,3 @@
DIST reno-2.11.2.tar.gz 74623 BLAKE2B 5c985a81fb6ef7926eadfd1b096f1a1358cb814100b75c6175b6507c2d9ce64f5a06799164a7593cc40f00695cf538c9a49bee1a4d0f78c115519d660681b315 SHA512 b2ef0d9112e327d3a581bfe9b4d6e47b7b4edaa3fe463716772438aab0dcee445d94aaa93bfc7036ead297206353ade73a34d148521ef5d25abe9ca5e655a13f
+DIST reno-2.11.3.tar.gz 73296 BLAKE2B a09c79c12945396425f2d3a45259e15e1fe8909df107de90884a51c87a5f4ac9f425907c1f9f401417d979e8762f80f188d2e783a7ff36541c107a9497a12746 SHA512 8d5bfe30c7a886d295d77b3d38e7fde09a8febacfacbf984f919bd5c813d81999870684f7da5b3e77a95436c912ea8e275b68548622462218356e23ad084140c
DIST reno-2.7.0.tar.gz 65269 BLAKE2B f3ba0e33246d40f7f16739f367ad313ce440cd33c6f03de268f2e02293446e0d3a043287c36492d8cae44b65c682c09d13ab0e2c86beffc23a85184ef27a751b SHA512 daf32dd7c08f9f75a9a334db8aa9e8c4fdad266bd5e68a43a87920751cf57549fba7906da26dc6c8f79b97bfaf51ad481f80ce99168cd65cfbd62848cb3d0cab
diff --git a/dev-python/reno/reno-2.11.3.ebuild b/dev-python/reno/reno-2.11.3.ebuild
new file mode 100644
index 000000000000..d0f96e1bc5e2
--- /dev/null
+++ b/dev-python/reno/reno-2.11.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"