summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-10 17:52:58 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-10 17:54:03 +0200
commit0708522eca6fd052f3f34f350a8690726c3a49fc (patch)
treec7c891bcd56f5f2333ac28bce3691f2ef00704c4
parentapp-admin/keepassxc: Removed old. (diff)
downloadgentoo-0708522eca6fd052f3f34f350a8690726c3a49fc.tar.gz
gentoo-0708522eca6fd052f3f34f350a8690726c3a49fc.tar.bz2
gentoo-0708522eca6fd052f3f34f350a8690726c3a49fc.zip
net-analyzer/tcpreplay: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-analyzer/tcpreplay/Manifest1
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.2.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-analyzer/tcpreplay/Manifest b/net-analyzer/tcpreplay/Manifest
index ecb79cc01a35..16cc14e45d66 100644
--- a/net-analyzer/tcpreplay/Manifest
+++ b/net-analyzer/tcpreplay/Manifest
@@ -1,2 +1,3 @@
DIST tcpreplay-4.1.2.tar.gz 2162175 SHA256 da483347e83a9b5df0e0dbb0f822a2d37236e79dda35f4bc4e6684fa827f25ea SHA512 3a7d125f38fe15070d666eacb4a5ef026a73ff850adec7ef3592966f38d1d155002792c5d5ac2476aa034d71be5f31b9dacd5be34af01a336149af3a42cad360 WHIRLPOOL e5ca80234655b3614eebd400954b53d958d08dbe91cf123db07935e5bebfb34ad40cd41a7a25a8d8ee684dbcaeda41c75a18503172830141dca022713b7814d6
DIST tcpreplay-4.2.1.tar.gz 3528019 SHA256 224b519e561d969b4bdb0e700c2283e036620e3cb5895d5aab2a7e4f27d21a79 SHA512 0ecfc6ec80c94b2ea001ea1fee31f06cfb265dcd7bb45cc09d480aa6ed2d11733b7383c54425805bfed02750e05339500f3d4de9b7c6054fa12f015153366875 WHIRLPOOL b6d1bbb0c18398b9f10562f1040780e4a058046e8b040a195fdf0a937ccfa9282fed520ec5478ed443b92fa322412bc6b3ff2040728393903acf2080eedbf350
+DIST tcpreplay-4.2.2.tar.gz 3597722 SHA256 e674166b54486db8f5417554ed88c06f44f368d70585c2897b0bc085009d8dd5 SHA512 5ae57957ab95790df8e880a53905e0e8e62b3a3d80f1fb2030e7bc360d8d4146335b48d7a5c02448edacafc146f2ea485086a824ce4e305eb3a34a8587ac46ae WHIRLPOOL 195ef1c28850e8a57f7cf520d4bb3e32e1bdc89a1e230176ac2334ff7b9f8026f24ef0d07ab9331e93ed106485ef3b501521fc4a8a3ba9752cabeb4f4d675dc5
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.2.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.2.2.ebuild
new file mode 100644
index 000000000000..ee0ea9dffd4b
--- /dev/null
+++ b/net-analyzer/tcpreplay/tcpreplay-4.2.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic
+
+DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
+LICENSE="BSD GPL-3"
+SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV/_/-}/${P/_/-}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="debug pcapnav +tcpdump"
+
+DEPEND="
+ >=sys-devel/autogen-5.18.4[libopts]
+ dev-libs/libdnet
+ >=net-libs/libpcap-0.9
+ tcpdump? ( net-analyzer/tcpdump )
+ pcapnav? ( net-libs/libpcapnav )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ docs/{CHANGELOG,CREDIT,HACKING,TODO}
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.1.0-enable-pcap_findalldevs.patch
+)
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|#include <dnet.h>|#include <dnet/eth.h>|g' \
+ src/common/sendpacket.c || die
+ sed -i \
+ -e 's|@\([A-Z_]*\)@|$(\1)|g' \
+ -e '/tcpliveplay_CFLAGS/s|$| $(LDNETINC)|g' \
+ -e '/tcpliveplay_LDADD/s|$| $(LDNETLIB)|g' \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # By default it uses static linking. Avoid that, bug 252940
+ econf \
+ $(use_enable debug) \
+ $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ --disable-local-libopts \
+ --enable-dynamic-link \
+ --enable-shared \
+ --with-libdnet \
+ --with-testnic2=lo \
+ --with-testnic=lo
+}
+
+src_test() {
+ if [[ ! ${EUID} -eq 0 ]]; then
+ ewarn "Some tests were disabled due to FEATURES=userpriv"
+ ewarn "To run all tests issue the following command as root:"
+ ewarn " # make -C ${S}/test"
+ emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ else
+ emake -j1 test || {
+ ewarn "Note, that some tests require eth0 iface to be UP." ;
+ die "self test failed - see ${S}/test/test.log" ; }
+ fi
+}