summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-23 15:28:01 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-23 15:28:01 -0400
commit07b9fe5ed37d431386dee086cd292b6b149ebbb5 (patch)
treebd4674797855f64bda3a00d6c0d54f07383bb093
parentsys-fs/ntfs3g: fix build w/newer glibc #580136 (diff)
downloadgentoo-07b9fe5ed37d431386dee086cd292b6b149ebbb5.tar.gz
gentoo-07b9fe5ed37d431386dee086cd292b6b149ebbb5.tar.bz2
gentoo-07b9fe5ed37d431386dee086cd292b6b149ebbb5.zip
sys-fs/ntfs3g: move symlinks back to /usr #578336
-rw-r--r--sys-fs/ntfs3g/metadata.xml2
-rw-r--r--sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild (renamed from sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild)10
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-fs/ntfs3g/metadata.xml b/sys-fs/ntfs3g/metadata.xml
index 51450c0c76e4..1b94ddb68933 100644
--- a/sys-fs/ntfs3g/metadata.xml
+++ b/sys-fs/ntfs3g/metadata.xml
@@ -27,6 +27,8 @@ file ownership, access right.
<flag name="ntfsprogs">Include internal version of ntfsprogs.</flag>
</use>
<upstream>
+ <bugs-to>http://tuxera.com/forum/</bugs-to>
<remote-id type="cpe">cpe:/a:ntfs-3g:ntfs-3g</remote-id>
+ <remote-id type="sourceforge">ntfs-3g</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild b/sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild
index 4222ccd6c90e..9a0aca841bd1 100644
--- a/sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
inherit eutils linux-info udev toolchain-funcs libtool
@@ -13,7 +12,8 @@ HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
-SLOT="0/86"
+# The subslot matches the SONAME major #.
+SLOT="0/87"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
IUSE="acl debug +external-fuse ntfsdecrypt +ntfsprogs static-libs suid xattr"
@@ -50,6 +50,11 @@ pkg_setup() {
src_prepare() {
epatch "${PATCHES[@]}"
+ # Keep the symlinks in the same place we put the main binaries.
+ # Having them in / when all the progs are in /usr is pointless.
+ sed -i \
+ -e 's:/sbin:$(sbindir):g' \
+ {ntfsprogs,src}/Makefile.in || die #578336
# Note: patches apply to Makefile.in, so don't run autotools here.
elibtoolize
}
@@ -60,7 +65,6 @@ src_configure() {
--prefix="${EPREFIX}"/usr \
--exec-prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --exec-prefix="${EPREFIX}"/usr \
$(use_enable debug) \
--enable-ldscript \
--disable-ldconfig \