summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-02-04 16:20:40 -0500
committerVirgil Dupras <vdupras@gentoo.org>2019-02-04 16:20:40 -0500
commit07c478522a0b5be995eb0cd74a95f74f48872068 (patch)
tree9fe980f39ecfa8b20ea0caf707605001b1cf181e
parentdev-python/pytest: fix xdist-related test failures (diff)
downloadgentoo-07c478522a0b5be995eb0cd74a95f74f48872068.tar.gz
gentoo-07c478522a0b5be995eb0cd74a95f74f48872068.tar.bz2
gentoo-07c478522a0b5be995eb0cd74a95f74f48872068.zip
dev-util/netsurf-buildsystem: build with empty WARNINGFLAGS
Closes: https://bugs.gentoo.org/642164 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-util/netsurf-buildsystem/files/gentoo-helpers-r1.sh19
-rw-r--r--dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7-r1.ebuild26
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/netsurf-buildsystem/files/gentoo-helpers-r1.sh b/dev-util/netsurf-buildsystem/files/gentoo-helpers-r1.sh
new file mode 100644
index 000000000000..9ac4354e386e
--- /dev/null
+++ b/dev-util/netsurf-buildsystem/files/gentoo-helpers-r1.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+netsurf_define_makeconf() {
+ NETSURF_MAKECONF=(
+ NSSHARED="${EROOT}"/usr/share/netsurf-buildsystem
+ LIBDIR="$(get_libdir)"
+ PREFIX="${EROOT}/usr"
+ Q=
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ HOST_CC="\$(CC)"
+ CCOPT=
+ CCNOOPT=
+ CCDBG=
+ LDDBG=
+ AR="$(tc-getAR)"
+ WARNFLAGS=
+ )
+}
diff --git a/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7-r1.ebuild b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7-r1.ebuild
new file mode 100644
index 000000000000..3cae740cce6f
--- /dev/null
+++ b/dev-util/netsurf-buildsystem/netsurf-buildsystem-1.7-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="buildsystem-${PV}"
+DESCRIPTION="Build system used for netsurf and its libs"
+HOMEPAGE="https://www.netsurf-browser.org"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~m68k-mint"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -e 's:/bin/which:which:' -i "makefiles/Makefile.tools" || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX=/usr install
+ insinto /usr/share/netsurf-buildsystem
+ newins "${FILESDIR}/gentoo-helpers-r1.sh" gentoo-helpers.sh
+}