summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-17 19:11:32 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-17 19:11:32 -0800
commit07f12629f4be3de438274439df2b2004d7f9024a (patch)
tree0f279e48010f86a803c8ed29aa9f4f5d5bc833d6
parentx11-drivers/xf86-input-wacom: Version bump to 0.34.0. (diff)
downloadgentoo-07f12629f4be3de438274439df2b2004d7f9024a.tar.gz
gentoo-07f12629f4be3de438274439df2b2004d7f9024a.tar.bz2
gentoo-07f12629f4be3de438274439df2b2004d7f9024a.zip
media-libs/vulkan-loader: Version bump to 1.0.33.0.
Package-Manager: portage-2.3.0
-rw-r--r--media-libs/vulkan-loader/Manifest1
-rw-r--r--media-libs/vulkan-loader/vulkan-loader-1.0.33.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/vulkan-loader/Manifest b/media-libs/vulkan-loader/Manifest
index af2a0b8afcc7..2daae4a12ec7 100644
--- a/media-libs/vulkan-loader/Manifest
+++ b/media-libs/vulkan-loader/Manifest
@@ -1 +1,2 @@
DIST vulkan-loader-1.0.30.0.tar.gz 2525490 SHA256 c72586930967dd815bbd6d1cf8a20378e360c06814c78c8c8e6896d97c9541dc SHA512 0dd35aa1203b5420c7edd5bc56d8fca13472674dfe126702e09c2776f2bf68c18b762e551d9d5fd2def1200c7c757c9e590dd8e08adbcb064401d327b9a42960 WHIRLPOOL 634595ca53faac69f3eb5cb25cec4e044577fb3ac69b131e8cfd411c576e15ded0a4e1f4a683c23a12fd4e1ab7c73d490ffa0cefa6653eedb8e5a993fc74d9f1
+DIST vulkan-loader-1.0.33.0.tar.gz 2570738 SHA256 b8aba6c614e4e95024384f7b239c39683fd36e1dc37f65f86793b8e2738d4445 SHA512 96ad3d3c82a4d0cbbc3c039ee8eb551ed939e56f8ed9470b37fd9429339cdbaa100f976d56dc3ab017c92c80283b24309a0b483f5435fb5394816a490cd7c8e8 WHIRLPOOL 11051fcd4fc092ecde0ad0dafeb7d38583e368ffc880253e658a34ace3ead890e0af4f859af31519fd396767a075ec7467f315eda3376074b0c4e5d5f757e0ba
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.0.33.0.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.0.33.0.ebuild
new file mode 100644
index 000000000000..270fcd4cf2ea
--- /dev/null
+++ b/media-libs/vulkan-loader/vulkan-loader-1.0.33.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5} )
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/KhronosGroup/Vulkan-LoaderAndValidationLayers/archive/sdk-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Vulkan-LoaderAndValidationLayers-sdk-${PV}"
+fi
+
+inherit python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://www.khronos.org/vulkan/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND=""
+
+DOCS=( README.md LICENSE.txt )
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=True
+ -DBUILD_TESTS=False
+ -DBUILD_LAYERS=False
+ -DBUILD_DEMOS=False
+ -DBUILD_VKJSON=False
+ -DBUILD_LOADER=True
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install() {
+ keepdir /etc/vulkan/icd.d
+
+ cd "${BUILD_DIR}/loader"
+ dolib libvulkan.so.1.*
+ dosym libvulkan.so.1.* /usr/$(get_libdir)/libvulkan.so.1
+ dosym libvulkan.so.1.* /usr/$(get_libdir)/libvulkan.so
+
+ cd "${S}"
+ insinto /usr/include/vulkan
+ doins include/vulkan/*.h
+ einstalldocs
+}