summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-11-05 09:53:42 +0100
committerMichał Górny <mgorny@gentoo.org>2017-11-05 13:19:59 +0100
commit084e045c4ba8a1f3ecc9f480cf4a93fef3b28451 (patch)
tree2448f49e77a42645eb9ff88a14befde9b5adfc70
parentdev-cpp/catch: Update git branches (diff)
downloadgentoo-084e045c4ba8a1f3ecc9f480cf4a93fef3b28451.tar.gz
gentoo-084e045c4ba8a1f3ecc9f480cf4a93fef3b28451.tar.bz2
gentoo-084e045c4ba8a1f3ecc9f480cf4a93fef3b28451.zip
dev-cpp/catch: Install using CMake
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild17
-rw-r--r--dev-cpp/catch/catch-9999.ebuild17
2 files changed, 12 insertions, 22 deletions
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
index b6b3d982a71b..4cad4e13c4b7 100644
--- a/dev-cpp/catch/catch-1.9999.ebuild
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -14,21 +14,16 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
}
src_install() {
- # same location as used in fedora
- insinto /usr/include/catch
- doins -r include/.
+ cmake-utils_src_install
dodoc -r docs/.
}
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index 41195675fe3b..5a244d42728d 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -13,21 +13,16 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="test"
-# CMake is only used to build & run tests, so override phases
-src_configure() { :; }
-src_compile() { :; }
-
-src_test() {
+src_configure() {
+ local mycmakeargs=(
+ -DNO_SELFTEST=$(usex !test)
+ )
cmake-utils_src_configure
- cmake-utils_src_compile
- cmake-utils_src_test
}
src_install() {
- # same location as used in fedora
- insinto /usr/include/catch
- doins -r include/.
+ cmake-utils_src_install
dodoc -r docs/.
}