summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-20 12:20:10 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-20 12:29:21 +0100
commit08ad4176f6470227fade4317802f7a0e085152f8 (patch)
tree328a992985017dc689bfe38af17931003641f624
parentdev-python/python-magic: Version Bump (diff)
downloadgentoo-08ad4176f6470227fade4317802f7a0e085152f8.tar.gz
gentoo-08ad4176f6470227fade4317802f7a0e085152f8.tar.bz2
gentoo-08ad4176f6470227fade4317802f7a0e085152f8.zip
dev-python/python-bugzilla: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/python-bugzilla/Manifest1
-rw-r--r--dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-bugzilla/Manifest b/dev-python/python-bugzilla/Manifest
index 8a57ce408e23..fffb6eb00355 100644
--- a/dev-python/python-bugzilla/Manifest
+++ b/dev-python/python-bugzilla/Manifest
@@ -1 +1,2 @@
DIST python-bugzilla-1.1.0.tar.gz 70841 SHA256 7e24b50269a994b77463575a75dd5c91a892ebc669289171bef4e0193f3d9549 SHA512 30192d6c1e76f3a79b5059916ad773704e6ce503d5d44fbc9e5d7b4ac18b062108d336d8d2e0d26e4cd21ba421fc607e4b3ca2bd5a1e362561708c05b8322d88 WHIRLPOOL 1a2209b89125807cfd6db9258c2a2ee87641921316d8f2dd9123c28f90ca78f52241e1ead9fda392cc026421fd84244418791150cdca6cf07d9f86a4a34b134e
+DIST python-bugzilla-1.2.2.tar.gz 76026 SHA256 e4606c325960f9e3eb90aac26014348c96160d77bbee09b7c31c211d38433922 SHA512 bb4ce43ffbf054097bd537404861848dd4ff5883fa63f156dfa90bea9f2e89cfaf0670980ec290a3d9c90cee268709b914e8bd5bd38b7f2e29c8d7fbd0215ac2 WHIRLPOOL cd37177dd5ebcf3016ab870d76e9a2bb655c3d6d0ef8884820d1646daad9f364c71c62d156bb3f60c5a4fffc5b92255f9db9da9c9771f2c95b7494fd294bc75a
diff --git a/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
new file mode 100644
index 000000000000..f29788a854a3
--- /dev/null
+++ b/dev-python/python-bugzilla/python-bugzilla-1.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python module for interacting with Bugzilla over XMLRPC"
+HOMEPAGE="https://github.com/python-bugzilla/python-bugzilla"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ || ( dev-python/python-magic[${PYTHON_USEDEP}] sys-apps/file[python,${PYTHON_USEDEP}] )
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"