summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-08-05 11:16:25 -0500
committerAustin English <wizardedit@gentoo.org>2016-08-05 11:35:21 -0500
commit093a48958c292939fefc1fccb2f08a844a2a1f39 (patch)
tree9641dfd10fb485e061e0b4aed629f9b573b987ea
parentgames-kids/tuxmath: remove deprecated games eclass (diff)
downloadgentoo-093a48958c292939fefc1fccb2f08a844a2a1f39.tar.gz
gentoo-093a48958c292939fefc1fccb2f08a844a2a1f39.tar.bz2
gentoo-093a48958c292939fefc1fccb2f08a844a2a1f39.zip
games-kids/tuxmathscrabble: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.3.0
-rw-r--r--games-kids/tuxmathscrabble/files/tuxmathscrabble-0.8.1-gentoo.patch8
-rw-r--r--games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild65
2 files changed, 69 insertions, 4 deletions
diff --git a/games-kids/tuxmathscrabble/files/tuxmathscrabble-0.8.1-gentoo.patch b/games-kids/tuxmathscrabble/files/tuxmathscrabble-0.8.1-gentoo.patch
index 691c29a3bb0e..0e104f2f586f 100644
--- a/games-kids/tuxmathscrabble/files/tuxmathscrabble-0.8.1-gentoo.patch
+++ b/games-kids/tuxmathscrabble/files/tuxmathscrabble-0.8.1-gentoo.patch
@@ -1,5 +1,5 @@
---- TuxMathScrabble/tms.py.old 2015-02-02 22:19:30.894373011 +0100
-+++ TuxMathScrabble/tms.py 2015-02-02 22:20:19.530320947 +0100
+--- a/TuxMathScrabble/tms.py 2015-02-02 22:19:30.894373011 +0100
++++ b/TuxMathScrabble/tms.py 2015-02-02 22:20:19.530320947 +0100
@@ -1258,7 +1258,7 @@
if not os.path.exists(infname):
@@ -9,8 +9,8 @@
if os.path.exists(candidate):
master_fname=candidate
---- .tms_config_master.old 2015-02-02 22:21:59.655216399 +0100
-+++ .tms_config_master 2015-02-02 22:25:33.754003432 +0100
+--- a/.tms_config_master 2015-02-02 22:21:59.655216399 +0100
++++ b/.tms_config_master 2015-02-02 22:25:33.754003432 +0100
@@ -380,66 +380,66 @@
'wtype':'wx.SpinCtrl',
},
diff --git a/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild b/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..90d7a25b21a3
--- /dev/null
+++ b/games-kids/tuxmathscrabble/tuxmathscrabble-0.8.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-single-r1 multilib
+
+MY_PN=TuxMathScrabble
+DESCRIPTION="math-version of the popular board game for children 4-10"
+HOMEPAGE="http://www.asymptopia.org/"
+SRC_URI="https://github.com/asymptopia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}
+ dev-python/wxpython[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ app-arch/unzip"
+RDEPEND="${CDEPEND}
+ dev-python/pygame[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ default
+
+ rm -f $(find . -name '*.pyc')
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:/usr/share/${MY_PN}:" \
+ ${MY_PN}/tms.py \
+ .tms_config_master \
+ || die "sed failed"
+ sed -i \
+ -e "s:python2.7-32:python:g" \
+ ${PN}.py || die "2nd sed failed"
+ python_fix_shebang .
+}
+
+src_install() {
+ newbin ${PN}.py ${PN}
+
+ insinto $(python_get_sitedir)
+ doins -r ${MY_PN}
+
+ insinto /usr/share/${MY_PN}
+ doins -r .tms_config_master Font
+
+ python_optimize
+
+ newicon tms.ico ${PN}.ico
+ make_desktop_entry ${PN} ${PN} /usr/share/pixmaps/${PN}.ico
+
+ dodoc CHANGES README
+}