summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-10 06:51:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-10 07:18:58 +0100
commit09f4657c6d8bb796d88e10d4000ca88821119e4f (patch)
treeec982797fa3d5e2bceb36ba04618af22c87854df
parentdev-python/pyperclip: Remove redundant versions (diff)
downloadgentoo-09f4657c6d8bb796d88e10d4000ca88821119e4f.tar.gz
gentoo-09f4657c6d8bb796d88e10d4000ca88821119e4f.tar.bz2
gentoo-09f4657c6d8bb796d88e10d4000ca88821119e4f.zip
dev-python/pyperclip: Enable python3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyperclip/pyperclip-1.7.0.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/pyperclip/pyperclip-1.7.0.ebuild b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
index fd006c598dbe..3fbc5b435e88 100644
--- a/dev-python/pyperclip/pyperclip-1.7.0.ebuild
+++ b/dev-python/pyperclip/pyperclip-1.7.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7})
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit distutils-r1 virtualx
DESCRIPTION="A cross-platform clipboard module for Python."
@@ -24,13 +24,11 @@ RDEPEND="
)
"
-python_prepare_all() {
- # make tests a proper module so setuptools can find the test suite
- touch tests/__init__.py || die
-
- distutils-r1_python_prepare_all
+python_test() {
+ "${EPYTHON}" tests/test_pyperclip.py -vv ||
+ die "Tests fail on ${EPYTHON}"
}
-python_test() {
- virtx esetup.py test
+src_test() {
+ virtx distutils-r1_src_test
}