summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-13 10:17:17 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-13 10:18:03 +0200
commit0a2705096d402a6f12adcdf60e3b6f64bf90715a (patch)
treee31168f50dacdba9a86ae4e1180fd6fca9a504c4
parentapp-admin/sudo: Bump to version 1.8.25_p1 (diff)
downloadgentoo-0a2705096d402a6f12adcdf60e3b6f64bf90715a.tar.gz
gentoo-0a2705096d402a6f12adcdf60e3b6f64bf90715a.tar.bz2
gentoo-0a2705096d402a6f12adcdf60e3b6f64bf90715a.zip
sys-apps/sg3_utils: Bump to version 1.44
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--sys-apps/sg3_utils/Manifest1
-rw-r--r--sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch8
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.44.ebuild44
3 files changed, 49 insertions, 4 deletions
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index 8b9347c15761..786e00243ea5 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1,2 +1,3 @@
DIST sg3_utils-1.42.tgz 1219231 BLAKE2B dd9ea2c324cb6f4c0ce770c90b7980da5e998bddc3a2be43a0aa9bea88dfe34291d0f58b393b2a5ac680c05dc673802ec9fae1ead37107bc49fa33bc7c4df503 SHA512 d16b65e36b2bccb4fc4c189f97e71fa38e6619f37d668a4ddd74a52c715fa62325288d9737812ed19c80547059dbd27be5a20565e27e1aabb571e8f5f8ac53ad
DIST sg3_utils-1.43.tar.gz 1180760 BLAKE2B 20475d974f9f4c0f275499a63f921b587df76e1b8addcd5201fd5db95e100eb0b4c8c97aba7e9651ae069c43e30cd7b780643212307dec6d53e5b91cd2c653e8 SHA512 5f2eea6f61300e288ce32ca613179a944de34576fd6e596c4c3aa6cc2c0ef397cf5bfd2c148b737f678aac0c574321994525486430ea14ae8e7cb1c02184636f
+DIST sg3_utils-1.44.tar.xz 922152 BLAKE2B 8596ef78fbb7ade5a969f485b0f4ff63863dc8a5ff58fe630cffa91900ba9946b47ddf857346aa3904da8502afa4928f54baf99428344d2e561a90e52c8533ed SHA512 4f4d5536ebed62f2c81c55741043d9ac3f4610a4dd6ef2e3125f041afd57aae03a32c2affe84a960c9f61fb6f84784bc901c756a8c36c1bc97082fa61e73ae8d
diff --git a/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch b/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch
index a82ab6add9a4..62fb30240e10 100644
--- a/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch
+++ b/sys-apps/sg3_utils/files/sg3_utils-1.26-stdint.patch
@@ -7,8 +7,8 @@ Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
For uint64_t to be available, <stdint.h> must be included:
http://www.opengroup.org/onlinepubs/009695399/basedefs/stdint.h.html
---- include/sg_cmds_basic.h 2008/06/26 23:27:40 1.1
-+++ include/sg_cmds_basic.h 2008/06/26 23:28:06
+--- a/include/sg_cmds_basic.h
++++ b/include/sg_cmds_basic.h
@@ -30,6 +30,8 @@
*
*/
@@ -18,8 +18,8 @@ http://www.opengroup.org/onlinepubs/009695399/basedefs/stdint.h.html
#ifdef __cplusplus
extern "C" {
#endif
---- include/sg_cmds_extra.h 2008/06/26 23:27:40 1.1
-+++ include/sg_cmds_extra.h 2008/06/26 23:29:02
+--- a/include/sg_cmds_extra.h
++++ b/include/sg_cmds_extra.h
@@ -30,6 +30,8 @@
*
*/
diff --git a/sys-apps/sg3_utils/sg3_utils-1.44.ebuild b/sys-apps/sg3_utils/sg3_utils-1.44.ebuild
new file mode 100644
index 000000000000..d98714db0ff7
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.44.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="http://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DEPEND="sys-devel/libtool"
+RDEPEND=""
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26-stdint.patch #580236
+)
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED%/}/"${path}/libsgutils2.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+
+ find "${ED}" -name "*.la" -delete || die
+}