summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 21:17:22 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 21:45:42 -0400
commit0c1935c827b591bab2814ea550dc09214bcc258e (patch)
treeca1cd1d3fce6ec6c5b8e641279e93187b4167967
parentdev-lang/go: add 1.18.7, 1.19.2 (diff)
downloadgentoo-0c1935c827b591bab2814ea550dc09214bcc258e.tar.gz
gentoo-0c1935c827b591bab2814ea550dc09214bcc258e.tar.bz2
gentoo-0c1935c827b591bab2814ea550dc09214bcc258e.zip
sci-misc/fitscut: EAPI6->8, remove dead urls
Also fix license and update deps. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--sci-misc/fitscut/fitscut-1.4.4-r1.ebuild (renamed from sci-misc/fitscut/fitscut-1.4.4.ebuild)29
1 files changed, 16 insertions, 13 deletions
diff --git a/sci-misc/fitscut/fitscut-1.4.4.ebuild b/sci-misc/fitscut/fitscut-1.4.4-r1.ebuild
index 918c52024dbc..01b7876239ae 100644
--- a/sci-misc/fitscut/fitscut-1.4.4.ebuild
+++ b/sci-misc/fitscut/fitscut-1.4.4-r1.ebuild
@@ -1,38 +1,41 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
DESCRIPTION="Extract cutouts from FITS image files"
-HOMEPAGE="http://acs.pha.jhu.edu/general/software/fitscut/"
-SRC_URI="http://acs.pha.jhu.edu/general/software/fitscut/download/${P}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
RDEPEND="
- sci-libs/cfitsio:0=
- sci-astronomy/wcstools:0=
- media-libs/libpng:0=
- virtual/jpeg:0="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ sci-astronomy/wcstools
+ sci-libs/cfitsio:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/${P}-fix-asinh.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-asinh.patch
+)
src_prepare() {
default
+
# gentoo wcs is called wcstools to avoid conflict with wcslib
sed -e 's/libwcs/wcs/g' \
-i wcs*.c fitscut.c || die
+
# cfitsio/fitsio.h might conflict with host on prefix
sed -e 's/LIB(wcs,/LIB(wcstools,/' \
-e 's/-lwcs/-lwcstools/' \
-e '/cfitsio\/fitsio.h/d' \
- configure.in > configure.ac || die
- rm configure.in
+ -i configure.in || die
+
eautoreconf
}