summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2022-06-26 21:18:57 +0200
committerSam James <sam@gentoo.org>2022-06-28 10:31:38 +0100
commit0e1e8ba45af1913742d440c63efde2390eca9e2c (patch)
treebf2d00f0774cfccdc35965cf0b247c94ca3d9966
parentdev-util/ROPgadget: version bump 6.8 (diff)
downloadgentoo-0e1e8ba45af1913742d440c63efde2390eca9e2c.tar.gz
gentoo-0e1e8ba45af1913742d440c63efde2390eca9e2c.tar.bz2
gentoo-0e1e8ba45af1913742d440c63efde2390eca9e2c.zip
mail-filter/imapfilter: add 5.4 & luajit to LUA_COMPAT, correctly depend on libpcre2
Closes: https://bugs.gentoo.org/828110 Closes: https://bugs.gentoo.org/854471 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/26082 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--mail-filter/imapfilter/imapfilter-2.7.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail-filter/imapfilter/imapfilter-2.7.5-r1.ebuild b/mail-filter/imapfilter/imapfilter-2.7.5-r1.ebuild
new file mode 100644
index 000000000000..6f25c2f85bc8
--- /dev/null
+++ b/mail-filter/imapfilter/imapfilter-2.7.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single toolchain-funcs
+
+DESCRIPTION="An IMAP mail filtering utility"
+HOMEPAGE="https://github.com/lefcha/imapfilter"
+SRC_URI="https://github.com/lefcha/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-libs/libpcre2
+ ${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS NEWS README samples/*"
+
+src_prepare() {
+ default
+ sed -i -e "/^PREFIX/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^MANDIR/s:man:share/man:" \
+ -e "/^CFLAGS/s:CFLAGS =:CFLAGS +=:" \
+ -e "/^CFLAGS/s/-O//" \
+ src/Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS}" \
+ INCDIRS=$(lua_get_CFLAGS) \
+ LIBLUA=$(lua_get_LIBS)
+}
+
+src_install() {
+ default
+ doman doc/imapfilter.1 doc/imapfilter_config.5
+}