summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-11-12 13:31:26 +0100
committerJustin Lecher <jlec@gentoo.org>2016-11-12 15:21:09 +0100
commit0ef493739ab8e589e5d4aaf7ee7dbc535ccab584 (patch)
treed798ccf1ec06538bf015ba5631609f2530ccae14
parentapp-editors/qxmledit: version bump (diff)
downloadgentoo-0ef493739ab8e589e5d4aaf7ee7dbc535ccab584.tar.gz
gentoo-0ef493739ab8e589e5d4aaf7ee7dbc535ccab584.tar.bz2
gentoo-0ef493739ab8e589e5d4aaf7ee7dbc535ccab584.zip
net-misc/mosh: Add missing slotoperator
Bump EAPI to 6 Package-Manager: portage-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--net-misc/mosh/metadata.xml40
-rw-r--r--net-misc/mosh/mosh-1.2.6.ebuild16
2 files changed, 27 insertions, 29 deletions
diff --git a/net-misc/mosh/metadata.xml b/net-misc/mosh/metadata.xml
index ee89d1f828e8..5aa0beb6000a 100644
--- a/net-misc/mosh/metadata.xml
+++ b/net-misc/mosh/metadata.xml
@@ -1,30 +1,30 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>xmw@gentoo.org</email>
- <name>Michael Weber</name>
-</maintainer>
-<maintainer type="person">
- <email>monsieurp@gentoo.org</email>
- <name>Patrice Clement</name>
-</maintainer>
-<use>
- <flag name="client">Build network client</flag>
- <flag name="examples">Include example scripts</flag>
- <flag name="mosh-hardening">Enable compiler and linker options to frustrate memory corruption exploits</flag>
- <flag name="server">Build network server</flag>
- <flag name="ufw">Install net-firewall/ufw rule set</flag>
- <flag name="utempter">Include libutempter support</flag>
-</use>
-<longdescription>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <use>
+ <flag name="client">Build network client</flag>
+ <flag name="examples">Include example scripts</flag>
+ <flag name="mosh-hardening">Enable compiler and linker options to frustrate memory corruption exploits</flag>
+ <flag name="server">Build network server</flag>
+ <flag name="ufw">Install net-firewall/ufw rule set</flag>
+ <flag name="utempter">Include libutempter support</flag>
+ </use>
+ <longdescription>
Mosh is a remote terminal application that supports:
- intermittent network connectivity,
- roaming to different IP address without dropping the connection, and
- intelligent local echo and line editing to reduce the effects
of "network lag" on high-latency connections.
</longdescription>
-<upstream>
- <bugs-to>https://github.com/keithw/mosh/issues</bugs-to>
-</upstream>
+ <upstream>
+ <bugs-to>https://github.com/keithw/mosh/issues</bugs-to>
+ </upstream>
</pkgmetadata>
diff --git a/net-misc/mosh/mosh-1.2.6.ebuild b/net-misc/mosh/mosh-1.2.6.ebuild
index a6a0d27c7b60..82441a869d29 100644
--- a/net-misc/mosh/mosh-1.2.6.ebuild
+++ b/net-misc/mosh/mosh-1.2.6.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit autotools bash-completion-r1 eutils vcs-snapshot
@@ -15,10 +15,12 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
IUSE="+client examples +mosh-hardening +server ufw +utempter"
-REQUIRED_USE="|| ( client server )
+REQUIRED_USE="
+ || ( client server )
examples? ( client )"
-RDEPEND="dev-libs/protobuf
+RDEPEND="
+ dev-libs/protobuf:0=
sys-libs/ncurses:0=
virtual/ssh
client? (
@@ -38,8 +40,8 @@ PATCHES=(
)
src_prepare() {
- # apply patches.
- epatch ${PATCHES[@]}
+ MAKEOPTS+=" V=1"
+ default
eautoreconf
}
@@ -55,10 +57,6 @@ src_configure() {
$(use_with utempter)
}
-src_compile() {
- emake V=1
-}
-
src_install() {
default