summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2016-01-13 16:29:08 -0200
committerGuilherme Amadio <amadio@gentoo.org>2016-01-13 16:29:31 -0200
commit0f23e5e245fff0bda02c6359814da3b0f9dd62c4 (patch)
tree24991a3aca75413d501399e58eac7265c8c4a9d2
parentgames-fps/doom3-mitm: EAPI=5; attempt at fixing bug #383321 (diff)
downloadgentoo-0f23e5e245fff0bda02c6359814da3b0f9dd62c4.tar.gz
gentoo-0f23e5e245fff0bda02c6359814da3b0f9dd62c4.tar.bz2
gentoo-0f23e5e245fff0bda02c6359814da3b0f9dd62c4.zip
sci-visualization/gwyddion: version bump to 2.44 (bug #571604)
Package-Manager: portage-2.2.26
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.44.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index 16e036ba67f8..5d8336b8c021 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1 +1,2 @@
DIST gwyddion-2.39.tar.xz 3130844 SHA256 f2346a706fa097e9186339f7e10b7837b20ce403b44bc7a85bc78b6b78a506d2 SHA512 5b9631c9eeb71a10d0be3533585eb61e8d27bc1147a1f3cf1ca333020271b579025ce752d302bd9474f1b3ed8c55ce679ac6a75bfb4a1093adef0727b824d435 WHIRLPOOL 90262b86d1bb01b6fdf5a67b447dc1177a523df368fbd040a87d7261e071844b86624dd6bb303c8a32302d16e5f7cb11e5f0744b2808e4f6d467cd27652efe23
+DIST gwyddion-2.44.tar.xz 3517624 SHA256 e7ee7545770a276e78fdff1b51e547d5d0ba39b94995da91e0d6797122b7eda5 SHA512 c80a0e4e9dde2f669763629d34dacc0015770c4704a10fc820f4d8e75b4f4275852162653f0c6c52674ed76162861af860de6741466d939066bfea3fb584d2ff WHIRLPOOL 56f78efb477da520a65473ce6be9eff88897198e8a80e5971a2280755fdc61925405c0a464572cf7887689746d140eefc855562569919bc17e057f472ac0b597
diff --git a/sci-visualization/gwyddion/gwyddion-2.44.ebuild b/sci-visualization/gwyddion/gwyddion-2.44.ebuild
new file mode 100644
index 000000000000..94ca373b991f
--- /dev/null
+++ b/sci-visualization/gwyddion/gwyddion-2.44.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils fdo-mime gnome2-utils python-single-r1
+
+DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
+HOMEPAGE="http://gwyddion.net/"
+SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fits fftw gnome kde nls opengl perl python ruby sourceview xml X"
+
+RDEPEND="
+ media-libs/libpng:0
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/pango
+ fits? ( sci-libs/cfitsio )
+ fftw? ( sci-libs/fftw:3.0 )
+ gnome? ( gnome-base/gconf:2 )
+ kde? ( kde-base/kdelibs:4 )
+ opengl? ( virtual/opengl x11-libs/gtkglext )
+ perl? ( dev-lang/perl )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
+ ruby? ( dev-ruby/narray )
+ sourceview? ( x11-libs/gtksourceview:2.0 )
+ xml? ( dev-libs/libxml2:2 )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+MAKEOPTS+=" V=1"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-rpath
+ $(use_enable doc gtk-doc)
+ $(use_enable nls)
+ $(use_enable python pygwy)
+ $(use_enable fits cfitsio)
+ $(use_with perl)
+ $(use_with python)
+ $(use_with ruby)
+ $(use_with fftw fftw3)
+ $(use_with opengl gl) \
+ $(use_with sourceview gtksourceview)
+ $(use_with xml libxml2)
+ $(use_with X x)
+ $(use_with kde kde4-thumbnailer)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use python && dodoc modules/pygwy/README.pygwy
+}
+
+pkg_postinst() {
+ use gnome && gnome2_gconf_install
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ use gnome && gnome2_gconf_uninstall
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}