summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-04-08 09:57:38 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-04-08 09:57:38 +0300
commit0f24827067ff6f59cd0290e37b36efed2f9c4c84 (patch)
treee089fb7e4f3957e7fcb54ee084bbd8f39e1304de
parentapp-arch/tar: sh stable wrt bug #681728 (diff)
downloadgentoo-0f24827067ff6f59cd0290e37b36efed2f9c4c84.tar.gz
gentoo-0f24827067ff6f59cd0290e37b36efed2f9c4c84.tar.bz2
gentoo-0f24827067ff6f59cd0290e37b36efed2f9c4c84.zip
app-arch/tar: Security cleanup
Closes: https://bugs.gentoo.org/681728 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--app-arch/tar/Manifest1
-rw-r--r--app-arch/tar/files/tar-1.31-remove-erroneous-abort-call.patch33
-rw-r--r--app-arch/tar/tar-1.31-r1.ebuild81
3 files changed, 0 insertions, 115 deletions
diff --git a/app-arch/tar/Manifest b/app-arch/tar/Manifest
index eeff245a6f19..64c7c860dbf4 100644
--- a/app-arch/tar/Manifest
+++ b/app-arch/tar/Manifest
@@ -1,2 +1 @@
-DIST tar-1.31.tar.bz2 2946047 BLAKE2B c85c17740e4cd3e8c93d10d93b070cd80629b7f052d020c0513cdddd377f3f90e229a6fa10dfbb43e1006f8202c674f2df854b864c0947f49339a52964d65c1c SHA512 0f4d00e08d56a8f8c32aac0afa2845397efb8ad72eaa6af47334cef9612adb1a4b91406bdc2c3a2cf1b9cc8b92c12735a331e0d137b24f66703f6af6219464f6
DIST tar-1.32.tar.bz2 2947264 BLAKE2B 4e380a9a2f84a2af5130464e1b298ae6acf02ee459cbca20dd0991c2859785e5aac789d57b87b32e8b45d89985b6414af9dd37161385da9568d6030c5aa42c0e SHA512 3139e87112123269ee0600243b3ea081687cc93667bef5832bfe3c785c1be622f520f00fcfbdf44ad1d3247866d0ecfe347a85bbfec38eb38fa1014baef566f6
diff --git a/app-arch/tar/files/tar-1.31-remove-erroneous-abort-call.patch b/app-arch/tar/files/tar-1.31-remove-erroneous-abort-call.patch
deleted file mode 100644
index 9e255df57602..000000000000
--- a/app-arch/tar/files/tar-1.31-remove-erroneous-abort-call.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 85c005ee1345c342f707f3c55317daf6cb050603 Mon Sep 17 00:00:00 2001
-From: Sergey Poznyakoff <gray@gnu.org.ua>
-Date: Thu, 10 Jan 2019 18:18:49 +0200
-Subject: Remove erroneous abort() call
-
-The call was introduced by commit ccef8581. It caused tar to abort
-on perfectly normal operations, like untarring archives containing
-./ with the -U option,
-
-See http://lists.gnu.org/archive/html/bug-tar/2019-01/msg00019.html
-for details.
-
-* src/extract.c (maybe_recoverable): Remove misplaced call to abort().
----
- src/extract.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/extract.c b/src/extract.c
-index 090b866..8276f8f 100644
---- a/src/extract.c
-+++ b/src/extract.c
-@@ -787,7 +787,7 @@ maybe_recoverable (char *file_name, bool regular, bool *interdir_made)
- case UNLINK_FIRST_OLD_FILES:
- break;
- }
-- abort (); /* notreached */
-+ FALLTHROUGH;
-
- case ENOENT:
- /* Attempt creating missing intermediate directories. */
---
-cgit v1.0-41-gc330
-
diff --git a/app-arch/tar/tar-1.31-r1.ebuild b/app-arch/tar/tar-1.31-r1.ebuild
deleted file mode 100644
index 72de0a507c72..000000000000
--- a/app-arch/tar/tar-1.31-r1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="https://www.gnu.org/software/tar/"
-SRC_URI="mirror://gnu/tar/${P}.tar.bz2
- mirror://gnu-alpha/tar/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="acl elibc_glibc minimal nls selinux static userland_GNU xattr"
-
-LIB_DEPEND="acl? ( virtual/acl[static-libs(+)] )"
-
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.10.35 )
- static? ( ${LIB_DEPEND} )
- xattr? ( elibc_glibc? ( sys-apps/attr ) )"
-
-PATCHES=( "${FILESDIR}"/${P}-remove-erroneous-abort-call.patch )
-
-src_prepare() {
- default
-
- if ! use userland_GNU ; then
- sed -i \
- -e 's:/backup\.sh:/gbackup.sh:' \
- scripts/{backup,dump-remind,restore}.in \
- || die "sed non-GNU"
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --bindir="${EPREFIX%/}"/bin
- --enable-backup-scripts
- --libexecdir="${EPREFIX%/}"/usr/sbin
- $(usex userland_GNU "" "--program-prefix=g")
- $(use_with acl posix-acls)
- $(use_enable nls)
- $(use_with selinux)
- $(use_with xattr xattrs)
- )
- FORCE_UNSAFE_CONFIGURE=1 econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- local p=$(usex userland_GNU "" "g")
- if [[ -z ${p} ]] ; then
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt
- fi
-
- # autoconf looks for gtar before tar (in configure scripts), hence
- # in Prefix it is important that it is there, otherwise, a gtar from
- # the host system (FreeBSD, Solaris, Darwin) will be found instead
- # of the Prefix provided (GNU) tar
- if use prefix ; then
- dosym tar /bin/gtar
- fi
-
- mv "${ED%/}"/usr/sbin/${p}backup{,-tar} || die
- mv "${ED%/}"/usr/sbin/${p}restore{,-tar} || die
-
- if use minimal ; then
- find "${ED%/}"/etc "${ED%/}"/*bin/ "${ED%/}"/usr/*bin/ \
- -type f -a '!' '(' -name tar -o -name ${p}tar ')' \
- -delete || die
- fi
-}