summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-22 11:30:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-22 11:32:38 +0200
commit0f4a055c9fc664f947324f547ea5dd141d035fb8 (patch)
tree70bb8fc8f2ab319fd4dbbc411b46ba12d11fd50c
parentdev-python/pyface: 6.0.0 version bump w/o keywords (diff)
downloadgentoo-0f4a055c9fc664f947324f547ea5dd141d035fb8.tar.gz
gentoo-0f4a055c9fc664f947324f547ea5dd141d035fb8.tar.bz2
gentoo-0f4a055c9fc664f947324f547ea5dd141d035fb8.zip
dev-python/pyface: Drop pyside/PyQt4 support
Bug: https://bugs.gentoo.org/649106 Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--dev-python/pyface/pyface-4.4.0-r1.ebuild38
-rw-r--r--dev-python/pyface/pyface-4.5.2-r1.ebuild43
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/pyface/pyface-4.4.0-r1.ebuild b/dev-python/pyface/pyface-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..db5771d83587
--- /dev/null
+++ b/dev-python/pyface/pyface-4.4.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ dev-python/wxpython:*[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=wx
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests" virtualmake -v -I 'composite_grid_model_test_case*' \
+ -I 'simple_grid_model_test_case*' \
+ -I 'test_split_editor_area_pane*'
+}
diff --git a/dev-python/pyface/pyface-4.5.2-r1.ebuild b/dev-python/pyface/pyface-4.5.2-r1.ebuild
new file mode 100644
index 000000000000..c68ecf3f3836
--- /dev/null
+++ b/dev-python/pyface/pyface-4.5.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# https://github.com/enthought/pyface/issues/40 confirms only py2.7
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Traits-capable windowing framework"
+HOMEPAGE="https://github.com/enthought/pyface"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ >=dev-python/traits-4.1[${PYTHON_USEDEP}]
+ dev-python/wxpython:*[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/traitsui[${PYTHON_USEDEP}]
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+python_test() {
+ export ETS_TOOLKIT=wx
+ # set nosetests to ignore tests unpassable by these vars.
+ VIRTUALX_COMMAND="nosetests" virtualmake -v -I 'composite_grid_model_test_case*' \
+ -I 'simple_grid_model_test_case*' \
+ -I 'test_split_editor_area_pane*'
+}
+
+python_install_all() {
+ use examples && EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}