summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-06 13:16:04 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-06 18:24:18 -0600
commit0f8a1d3706df2b81a2c4a2a7282b3eb0972cfcd7 (patch)
tree76da1ca6d78f8ccdaf44f9aefd72cd34007a52de
parentsci-mathematics/prover9: eapi=7, add src_test (diff)
downloadgentoo-0f8a1d3706df2b81a2c4a2a7282b3eb0972cfcd7.tar.gz
gentoo-0f8a1d3706df2b81a2c4a2a7282b3eb0972cfcd7.tar.bz2
gentoo-0f8a1d3706df2b81a2c4a2a7282b3eb0972cfcd7.zip
app-admin/ansible: 2.9.2 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.9.1.ebuild68
-rw-r--r--app-admin/ansible/ansible-2.9.2.ebuild2
3 files changed, 1 insertions, 70 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 56efb415d3cf..a3e6abd067af 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,4 +1,3 @@
DIST ansible-2.7.15.tar.gz 10205890 BLAKE2B 30b0c83ad646cdcd918472be4512ee8cf00e966b9c7ed0431bcf915e858dae6aeb26cdff4eee5d480b751a4c33f30c2b213d8bc67d17bc8774c5ca2bcf897632 SHA512 7140fdb80456f5dd9f34226a9f38ce567ad13e4cd6b4058ae22012867554c9ed19e3cfa0ae7e745bf56d109fbe8dde8e264efce2f537b5bdae48cf606ee38f52
DIST ansible-2.8.7.tar.gz 12697144 BLAKE2B f88225b358ff9fad352c04a053100c5aa612f54ba7ad8e3a700d61e030fd0b5850055b83861d3ad76e614d3e786a2ed719f63b7f452ce24d7e27d79d386b8eed SHA512 166009780c8bb5b35beb9604412d4e5e3874e13b04f3ce694d726dc5bfb064f73a17ec3c814c8a67e28d57e7c327276b6cb66a9a0dba7138d702427ec13b4de3
-DIST ansible-2.9.1.tar.gz 14144123 BLAKE2B 20b288aed59221c63cbc345d6f1bb33770b864229ddfdcb3e3d7c5ddde0978b05f1139466945a92145772f1d659a43d406c7486df91f7f16135f66b7282761ab SHA512 fdb25017b96475a6c182bba2f32050f0eaa6f22d17f166b98ce0f0cb40fd12dbbc5ede9912624fa4c5d4a8de472b28c2eb2b569700537c7d4b4c568d7e38f21b
DIST ansible-2.9.2.tar.gz 14157188 BLAKE2B 4c1207bd43f7797d8d9cb1d4612e866eebbf8c19ee060cf1eb7daa68415be5d7718c79d756454648e66a13434eacba6a07c8de31c4ec4b12e0474563d8844e46 SHA512 522dd84af9493ceafd95ff0fc806a671f3d1f10d0ca074ef41875eb966d39e64b834e0b98a35d81d9d9d96efef8069db604c8080ce8cbb1ce2e8b13bf5c30a6a
diff --git a/app-admin/ansible/ansible-2.9.1.ebuild b/app-admin/ansible/ansible-2.9.1.ebuild
deleted file mode 100644
index 205e178f21d9..000000000000
--- a/app-admin/ansible/ansible-2.9.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}
diff --git a/app-admin/ansible/ansible-2.9.2.ebuild b/app-admin/ansible/ansible-2.9.2.ebuild
index 87aa8f15ecba..205e178f21d9 100644
--- a/app-admin/ansible/ansible-2.9.2.ebuild
+++ b/app-admin/ansible/ansible-2.9.2.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x64-macos"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~x64-macos"
IUSE="doc test"
RESTRICT="test"