summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-28 09:06:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-28 09:06:29 +0200
commit0ff1ed287eaf4152bc1308c70202f027570e2e18 (patch)
tree76a3ca2adb2928100d54df11a7f9265b20d9a486
parentmedia-libs/sdl2-ttf: needs virtual/opengl (bug #581412; version bump (diff)
downloadgentoo-0ff1ed287eaf4152bc1308c70202f027570e2e18.tar.gz
gentoo-0ff1ed287eaf4152bc1308c70202f027570e2e18.tar.bz2
gentoo-0ff1ed287eaf4152bc1308c70202f027570e2e18.zip
sys-apps/logwatch: Bump to version 7.4.3
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/logwatch/Manifest1
-rw-r--r--sys-apps/logwatch/logwatch-7.4.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/logwatch/Manifest b/sys-apps/logwatch/Manifest
index 26f6c6c5c1c7..fdbb8d9f80de 100644
--- a/sys-apps/logwatch/Manifest
+++ b/sys-apps/logwatch/Manifest
@@ -1,3 +1,4 @@
DIST logwatch-7.4.0_p170.tar.gz 455794 SHA256 27f4ae2692190aa96a3af997d66b39a595e9c72e4a078cbdfa7c13f5c885a42f SHA512 6c07cfb20c0bd121b698b48f060d50b45e018b81b2ed78c96d33c5b8cb43fd23a139cf95c64af9c3148c99fe1f9e9d2c0936e1d2ab6dfba105e4ad621db2fcdb WHIRLPOOL 6af221787ce7d71f0c238fbb18d3b272cfe42cb18a3a24a70fbf617f2a6d39fd41d4978dd2c8b67687fa003594300e4beb2fc0b2f0c2425cc1c6fd1d501cda50
DIST logwatch-7.4.1.tar.gz 464970 SHA256 35ec31f9fe981aaa727b144ab3ff2eb655997d8ccabaf66586458f5dfc3a56eb SHA512 f53400e6654b498371265ade82d51f0625904a33400f7f82b2dc8522ad561c8998fd9f23d569281f031142bb527fc1b38af1d7534fe3b3aef23780b0152e67d4 WHIRLPOOL 947f0796f5313c9eb5aff3cca8b47a861eda3ff0b3b65134a11792ddca2262fbd8fd0bdf83ce430d06efb4905187ca82a6978e6b5ae656ade63a7d181cc3faac
DIST logwatch-7.4.2.tar.gz 491073 SHA256 006e122a1973bb12b92eb79622ebc93716ec0766a6987e73b4ae5387509e5ade SHA512 aed19220ccbe70a39148e0cdcfe421e7cf744d06d01e4decc88980f3e9e97f85f1cc40aee9a8857fb123a41ffb001afa75eeccdfcdc001073057d39a01875cb2 WHIRLPOOL 1b05288e4af8f0a608aa658df43a351dec6b958f77b0646d2eb45d8349ad7c5030327745a2a8ebc1e2e432dc74abf20a1303f266ef97cf24f89b74bef5cb141f
+DIST logwatch-7.4.3.tar.gz 462552 SHA256 1dbdc48d65e150f2dbb43f1e4f4700d94166e053b1c7bbbdedf4ad670283720e SHA512 716d87238f487010f2bdf230fc66c16f3c3fe769e6bef04b0e7881c6b0563e1a4b4741235b8a40a16ab21d3803562e87e6bcf5cfbd0ace42414f1d1feae7a13a WHIRLPOOL abe7870020029f86f037f4c96dff96b6c542eb36df9f110c755d6de28965c6418dd4d03a2e6932ff8db7079f22ea396d352aa6b8ebba81576b588017b4694d02
diff --git a/sys-apps/logwatch/logwatch-7.4.3.ebuild b/sys-apps/logwatch/logwatch-7.4.3.ebuild
new file mode 100644
index 000000000000..454da10e06d8
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.4.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/Date-Manip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.4.2-openssh-hpn.patch
+}
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+}