summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 20:36:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 20:41:32 +0200
commit101952b2a94e4017cb1ca94cbe093230f6c39b9b (patch)
tree542a0ed0fa6b633d6f984e65273c4e4b6b196532
parentsys-devel/llvm: Add 12.0.0.9999 for master branch (diff)
downloadgentoo-101952b2a94e4017cb1ca94cbe093230f6c39b9b.tar.gz
gentoo-101952b2a94e4017cb1ca94cbe093230f6c39b9b.tar.bz2
gentoo-101952b2a94e4017cb1ca94cbe093230f6c39b9b.zip
dev-python/lit: Add 12.0.0.9999 for master branch
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-12.0.0.9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lit/lit-12.0.0.9999.ebuild b/dev-python/lit/lit-12.0.0.9999.ebuild
new file mode 100644
index 000000000000..b9123ef7bf14
--- /dev/null
+++ b/dev-python/lit/lit-12.0.0.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}