summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-07 09:27:35 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-07 09:27:49 +0200
commit111d4b6671426385476cbc1da675b5efe6ee0e76 (patch)
tree857f86b2bfb10cf0ee813e635a8a72c3c9d937a7
parenteclass/cron: replace old gorg url to avoid redundant redirection (diff)
downloadgentoo-111d4b6671426385476cbc1da675b5efe6ee0e76.tar.gz
gentoo-111d4b6671426385476cbc1da675b5efe6ee0e76.tar.bz2
gentoo-111d4b6671426385476cbc1da675b5efe6ee0e76.zip
media-video/dvdauthor: Use pkg-config to find freetype
Bug: https://bugs.gentoo.org/654884 Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--media-video/dvdauthor/dvdauthor-0.7.2-r2.ebuild6
-rw-r--r--media-video/dvdauthor/files/dvdauthor-freetype_pkgconfig.patch43
2 files changed, 48 insertions, 1 deletions
diff --git a/media-video/dvdauthor/dvdauthor-0.7.2-r2.ebuild b/media-video/dvdauthor/dvdauthor-0.7.2-r2.ebuild
index 6ac055e70b4b..e7b36f67d408 100644
--- a/media-video/dvdauthor/dvdauthor-0.7.2-r2.ebuild
+++ b/media-video/dvdauthor/dvdauthor-0.7.2-r2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs
DESCRIPTION="Tools for generating DVD files to be played on standalone DVD players"
HOMEPAGE="http://dvdauthor.sourceforge.net/"
@@ -28,9 +28,13 @@ S="${WORKDIR}/${PN}"
DOCS=( AUTHORS ChangeLog README TODO )
+PATCHES=( "${FILESDIR}/${PN}-freetype_pkgconfig.patch" )
+
src_prepare() {
default
+ eautoreconf
+
if use imagemagick && has_version '>=media-gfx/imagemagick-7.0.1.0' ; then
eapply "${FILESDIR}/${PN}-0.7.2-imagemagick7.patch"
fi
diff --git a/media-video/dvdauthor/files/dvdauthor-freetype_pkgconfig.patch b/media-video/dvdauthor/files/dvdauthor-freetype_pkgconfig.patch
new file mode 100644
index 000000000000..bb9858f437d4
--- /dev/null
+++ b/media-video/dvdauthor/files/dvdauthor-freetype_pkgconfig.patch
@@ -0,0 +1,43 @@
+From 259f892fe61f16c26733506d2511eec7ff136dc4 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Mon, 7 May 2018 09:18:48 +0200
+Subject: [PATCH] Use pkg-config to find freetype
+
+As of freetype-2.9.1 the freetype-config file no longer gets installed
+by default.
+---
+ configure.ac | 10 ++++------
+ 1 file changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c06ac6b..1194059 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -79,10 +79,8 @@ PKG_CHECK_MODULES([FRIBIDI], [fribidi], [AC_DEFINE(HAVE_FRIBIDI, 1, [whether Fri
+ AC_SUBST(FRIBIDI_CFLAGS)
+ AC_SUBST(FRIBIDI_LIBS)
+
+-AC_CHECK_PROGS(FREETYPECONFIG, [freetype-config])
+-if test -n "$FREETYPECONFIG"; then
+- FREETYPE_CPPFLAGS="`$FREETYPECONFIG --cflags`"
+- FREETYPE_LIBS="`$FREETYPECONFIG --libs $config_static`"
++PKG_CHECK_MODULES(FREETYPE, [freetype2],[
++ FREETYPE_CPPFLAGS="$FREETYPE_CFLAGS"
+ AC_DEFINE(HAVE_FREETYPE, 1, [Whether FreeType is available])
+
+ ac_save_CPPFLAGS="$CPPFLAGS"
+@@ -91,9 +89,9 @@ if test -n "$FREETYPECONFIG"; then
+ CPPFLAGS="$ac_save_CPPFLAGS"
+ AC_SUBST(FREETYPE_CPPFLAGS)
+ AC_SUBST(FREETYPE_LIBS)
+-else
++ ],
+ AC_MSG_ERROR([freetype not found])
+-fi
++)
+
+
+ AC_ARG_ENABLE([default-video-format],
+--
+2.17.0
+