summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-05 15:23:33 +0200
committerMike Gilbert <floppym@gentoo.org>2016-09-10 10:01:29 -0400
commit115041505b9b6b2c5902e385bf0726e8e3d47575 (patch)
treeea980f2212dea85d7963d1ab7e69d9004ddca6e3
parentnet-misc/spice-gtk: Call addpredict in appropriate functions, bug #593388 (diff)
downloadgentoo-115041505b9b6b2c5902e385bf0726e8e3d47575.tar.gz
gentoo-115041505b9b6b2c5902e385bf0726e8e3d47575.tar.bz2
gentoo-115041505b9b6b2c5902e385bf0726e8e3d47575.zip
dev-lang/python: Fix cross-compilation support for 3.4.5
Gentoo-bug: https://bugs.gentoo.org/show_bug.cgi?id=590530 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2247
-rw-r--r--dev-lang/python/files/python-3.4.5-cross.patch11
-rw-r--r--dev-lang/python/python-3.4.5.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-lang/python/files/python-3.4.5-cross.patch b/dev-lang/python/files/python-3.4.5-cross.patch
new file mode 100644
index 000000000000..7a016ffbd488
--- /dev/null
+++ b/dev-lang/python/files/python-3.4.5-cross.patch
@@ -0,0 +1,11 @@
+--- a/Lib/distutils/command/build_ext.py
++++ b/Lib/distutils/command/build_ext.py
+@@ -729,7 +729,7 @@
+ if sysconfig.get_config_var('Py_ENABLE_SHARED'):
+ pythonlib = 'python{}.{}{}'.format(
+ sys.hexversion >> 24, (sys.hexversion >> 16) & 0xff,
+- sys.abiflags)
++ sysconfig.get_config_var('ABIFLAGS'))
+ return ext.libraries + [pythonlib]
+ else:
+ return ext.libraries
diff --git a/dev-lang/python/python-3.4.5.ebuild b/dev-lang/python/python-3.4.5.ebuild
index b26c787b02e9..11359e7cb316 100644
--- a/dev-lang/python/python-3.4.5.ebuild
+++ b/dev-lang/python/python-3.4.5.ebuild
@@ -72,6 +72,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
epatch "${FILESDIR}/${PN}-3.4.3-ncurses-pkg-config.patch"
+ epatch "${FILESDIR}/${PN}-3.4.5-cross.patch"
epatch_user