summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-09 16:05:34 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-09 16:10:02 +0100
commit11bf4a50302e098f8f41a11b18b031402d2f59b6 (patch)
tree0b9aabdecb53a54885d6e90e013541a204f431dc
parentdev-python/markdown: Add python3.5 support (diff)
downloadgentoo-11bf4a50302e098f8f41a11b18b031402d2f59b6.tar.gz
gentoo-11bf4a50302e098f8f41a11b18b031402d2f59b6.tar.bz2
gentoo-11bf4a50302e098f8f41a11b18b031402d2f59b6.zip
dev-python/bokeh: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/bokeh/Manifest1
-rw-r--r--dev-python/bokeh/bokeh-0.10.0.ebuild66
-rw-r--r--dev-python/bokeh/bokeh-0.7.1.ebuild2
-rw-r--r--dev-python/bokeh/metadata.xml4
4 files changed, 72 insertions, 1 deletions
diff --git a/dev-python/bokeh/Manifest b/dev-python/bokeh/Manifest
index 8a4393da9717..43003de33366 100644
--- a/dev-python/bokeh/Manifest
+++ b/dev-python/bokeh/Manifest
@@ -1 +1,2 @@
+DIST bokeh-0.10.0.tar.gz 4474129 SHA256 2d8bd8c98e2f62b2a28328d3cc95bfbe257742fa7efc9c382b4c8ae4a141df14 SHA512 19023f1e67245005581b8640380045a8795747da75025478881f9d3791e82289ee75b74142b38a0bae9c236c0b1b6df1629376d5c3fcc319ceafb0a4abc7240f WHIRLPOOL 86e8e3774287164d2d7da0a04ceddb62eb03a19e48c82acf806c1a356d361f655bd6087f15b740ab36b84891ed849435e2a9c6098e881f07299cce8553d88fb2
DIST bokeh-0.7.1.tar.gz 30039486 SHA256 167125e07df2ea1f65b1b6dfed140b7b6ed7452a1182ad4cb0be2580af537f73 SHA512 cf2ee6457cab7ca0a98c2cf19a7814e081245b30cf6f4f4670f8fc60b216bb39f14d3cdf52c92f85635cbf6419db00c0c01adb2e1a6eeaa019cdc767c642c160 WHIRLPOOL 23e66370f1cab2d3a3c40b0713e5cdb50afa7aeec1c2d1172a1d9a5598c004dd351509973ac84f24ebb30dbc5a86de455e1dfcbe00daf6a1d12c3e336122a2b8
diff --git a/dev-python/bokeh/bokeh-0.10.0.ebuild b/dev-python/bokeh/bokeh-0.10.0.ebuild
new file mode 100644
index 000000000000..8a80bce7aff9
--- /dev/null
+++ b/dev-python/bokeh/bokeh-0.10.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 readme.gentoo
+
+DESCRIPTION="Statistical and novel interactive HTML plots for Python"
+HOMEPAGE="http://bokeh.pydata.org/ http://github.com/bokeh/bokeh http://pypi.python.org/pypi/bokeh"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+# A doc build requires napoleon sphinx extension which will be included in sphinx release 1.3
+# Therefore refraining from adding the doc build for now
+RDEPEND="
+ dev-python/abstract_rendering[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.2.7[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.11[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-2.7.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ >=dev-python/werkzeug-0.9.1[${PYTHON_USEDEP}]
+ >=www-servers/tornado-4.0.1[${PYTHON_USEDEP}]
+ "
+# testing server: needs websocket not in portage yet
+# websocket is in pypi for the adding
+# hdf5 backend: needs array management not in portage yet
+DEPEND="${REDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+ "
+DOCS=( CHANGELOG QUICKSTART.md README.md )
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # exclude server tests for now
+ nosetests -v \
+ -e multiuser_auth_test \
+ -e usermodel_test \
+ || die
+}
+
+python_install_all() {
+ readme.gentoo_create_doc
+
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/bokeh/bokeh-0.7.1.ebuild b/dev-python/bokeh/bokeh-0.7.1.ebuild
index cf10e0e50192..048fbe2ede25 100644
--- a/dev-python/bokeh/bokeh-0.7.1.ebuild
+++ b/dev-python/bokeh/bokeh-0.7.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1 readme.gentoo
diff --git a/dev-python/bokeh/metadata.xml b/dev-python/bokeh/metadata.xml
index e88bff661521..e85a7b98e40c 100644
--- a/dev-python/bokeh/metadata.xml
+++ b/dev-python/bokeh/metadata.xml
@@ -12,5 +12,9 @@
<upstream>
<remote-id type="pypi">bokeh</remote-id>
<remote-id type="github">ContinuumIO/bokeh</remote-id>
+ <maintainer status="unknown">
+ <email>info@continuum.io</email>
+ <name>Continuum Analytics</name>
+ </maintainer>
</upstream>
</pkgmetadata>