summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-06 14:33:02 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-06 14:45:40 -0500
commit11db0f78b0edd2b81f64b53ed12f2d586827d1cf (patch)
tree3b4e4c78614854fb7909ed04f446bd2c5aafc6ce
parentgames-action/geki2-KXL: remove deprecated games eclass (diff)
downloadgentoo-11db0f78b0edd2b81f64b53ed12f2d586827d1cf.tar.gz
gentoo-11db0f78b0edd2b81f64b53ed12f2d586827d1cf.tar.bz2
gentoo-11db0f78b0edd2b81f64b53ed12f2d586827d1cf.zip
games-action/geki3-KXL: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
-rw-r--r--games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch16
-rw-r--r--games-action/geki3-KXL/geki3-KXL-1.0.3-r3.ebuild53
2 files changed, 61 insertions, 8 deletions
diff --git a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
index 039b185d0b1c..26f3f4371b85 100644
--- a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
+++ b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
@@ -1,13 +1,13 @@
---- bmp/Makefile.am
-+++ bmp/Makefile.am
+--- a/bmp/Makefile.am
++++ b/bmp/Makefile.am
@@ -1,4 +1,4 @@
-bmpdir = $(prefix)/share/geki3/bmp
+bmpdir = $(BMP_PATH)
bmp_DATA = back1.bmp boss2.bmp enemyshot1.bmp missile.bmp\
pata.bmp back2.bmp boss3.bmp enemyshot2.bmp mogu.bmp\
pata_ball.bmp back3.bmp boss4.bmp frame.bmp mogu_ball.bmp\
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -25,9 +25,9 @@
BMP_PATH=/usr/local/share/geki3/bmp
WAV_PATH=/usr/local/share/geki3/wav
@@ -21,8 +21,8 @@
fi
AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
---- data/Makefile.am
-+++ data/Makefile.am
+--- a/data/Makefile.am
++++ b/data/Makefile.am
@@ -1,6 +1,4 @@
-datadir = $(prefix)/share/geki3/data
+datadir = $(DATA_PATH)
@@ -31,8 +31,8 @@
-install:
- $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
---- wav/Makefile.am
-+++ wav/Makefile.am
+--- a/wav/Makefile.am
++++ b/wav/Makefile.am
@@ -1,4 +1,4 @@
-wavdir = $(prefix)/share/geki3/wav
+wavdir = $(WAV_PATH)
diff --git a/games-action/geki3-KXL/geki3-KXL-1.0.3-r3.ebuild b/games-action/geki3-KXL/geki3-KXL-1.0.3-r3.ebuild
new file mode 100644
index 000000000000..3d796f0f9ca6
--- /dev/null
+++ b/games-action/geki3-KXL/geki3-KXL-1.0.3-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils user
+
+DESCRIPTION="2D length scroll shooting game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-paths.patch
+)
+
+pkg_setup(){
+ enewgroup gamestat 36
+}
+
+src_prepare() {
+ default
+ rm -f missing
+ sed -i \
+ -e '1i #include <string.h>' \
+ -e "s:DATA_PATH \"/.score\":\"/var/games/${PN}\":" \
+ src/ranking.c || die
+ sed -i -e '/CFLAGS/s/$/ @CFLAGS@/' src/Makefile.am || die #bug 426890
+ mv configure.{in,ac}
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ insinto /var/games/${PN}
+ newins data/.score ${PN}
+ fowners root:gamestat /var/games/${PN} /usr/bin/geki3
+ fperms 660 /var/games/${PN}
+ fperms 2755 /usr/bin/geki3
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry geki3 Geki3
+}