summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-05-28 21:48:46 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-05-30 01:24:50 +0200
commit121d5f974bfdc485c15f3efdb02e629ba1159b93 (patch)
tree84949ed2016f3e708c15936e3a2126987ea3f02e
parentdev-perl/Net-DNS: Bump to version 1.100.0 (diff)
downloadgentoo-121d5f974bfdc485c15f3efdb02e629ba1159b93.tar.gz
gentoo-121d5f974bfdc485c15f3efdb02e629ba1159b93.tar.bz2
gentoo-121d5f974bfdc485c15f3efdb02e629ba1159b93.zip
app-vim/vimclojure: version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-vim/vimclojure/Manifest1
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-vim/vimclojure/Manifest b/app-vim/vimclojure/Manifest
index 19d9b16ae744..fba0de890885 100644
--- a/app-vim/vimclojure/Manifest
+++ b/app-vim/vimclojure/Manifest
@@ -1 +1,2 @@
DIST 2.3.6.zip 44737 SHA256 7c1a9197e8ed2540c921a4e448c88d784740de891cfe58c57e19e9c5c499cd5b SHA512 daf4f691500c3b901a57849c6f07b500c49f7086e0733921f589e362a53a0d07b99eab7d6ea42f1828822942b294f51a684eec93ebab1797438da4b81199ca9d WHIRLPOOL b908cf86313cdd3521f15c2090cbb9f4f2a8a7c656ff1a152fa3707f62e1c6a49fbf6dcf2d596107e6cb2ab579f9aa3e5aec60d04fc91a8f08396bb813b43481
+DIST vimclojure-2.3.6.zip 44737 SHA256 7c1a9197e8ed2540c921a4e448c88d784740de891cfe58c57e19e9c5c499cd5b SHA512 daf4f691500c3b901a57849c6f07b500c49f7086e0733921f589e362a53a0d07b99eab7d6ea42f1828822942b294f51a684eec93ebab1797438da4b81199ca9d WHIRLPOOL b908cf86313cdd3521f15c2090cbb9f4f2a8a7c656ff1a152fa3707f62e1c6a49fbf6dcf2d596107e6cb2ab579f9aa3e5aec60d04fc91a8f08396bb813b43481
diff --git a/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild b/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild
new file mode 100644
index 000000000000..2bf1249e8565
--- /dev/null
+++ b/app-vim/vimclojure/vimclojure-2.3.6-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="VimClojure"
+
+DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
+HOMEPAGE="https://github.com/vim-scripts/VimClojure"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.zip -> ${P}.zip"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="dev-lang/clojure"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( doc/LICENSE.txt )
+
+# Files with similar names are already installed by app-vim/slimv.
+DUPLICATE_FILES=(
+ indent/clojure.vim
+ ftdetect/clojure.vim
+)
+
+src_prepare() {
+ default
+
+ # Remove .bat files.
+ find . -type f -name \*.bat -exec rm -v {} \; || die
+
+ # Let's simply rename ${DUPLICATE_FILES[@]}.
+ local f
+ for f in "${DUPLICATE_FILES[@]}"; do
+ [[ -f "${f}" ]] || die "Couldn't find ${f}"
+ bname="${f##*/}"
+ path="${f%/*}"
+ noext="${bname%%.*}"
+ newname="${path}/${PN}_${noext}.vim"
+ mv -v "${f}" "${newname}" || die
+ done
+}
+
+src_install() {
+ einstalldocs
+ rm -rv "${DOCS[@]}" bin || die
+ vim-plugin_src_install
+}