summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-01 22:58:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-01 23:12:24 +0200
commit122105e7dc2382f94c449f9bc43344648cf4b4ed (patch)
treecaa12d91764b567c099307e1f3ab7fa96008ac3a
parentprofiles: add removal date for dev-util/intel-graphics-compiler (diff)
downloadgentoo-122105e7dc2382f94c449f9bc43344648cf4b4ed.tar.gz
gentoo-122105e7dc2382f94c449f9bc43344648cf4b4ed.tar.bz2
gentoo-122105e7dc2382f94c449f9bc43344648cf4b4ed.zip
dev-python/humanize: Bump to 3.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.11.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 4d4a890111f6..da21d1659948 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.10.0.tar.gz 65658 BLAKE2B c60aff8f5e2044c10e997f3546b30e8ac7c040ee57aea5342ccce7ea6341a8695c1b94bdc8cb2acc18c3f421667fd4090b7b110b47aa229cd10d5ac8b42d6dae SHA512 f31929ddc1055fb54294b67e25e3b41883ef4e8ff9b76082cdd4703d64a066d0a368d116a60e26465f07dd3a0df8c87bb459ff1b03153d8843d3eefb06ff6961
+DIST humanize-3.11.0.tar.gz 67034 BLAKE2B 9e10582139578e8e041d1ce60c9c5d7e071c4c093a64cf620df6ff38f0567e8b2f3134f10722cb724d13343373db0fa2a1ae5bd68700ff85fb58ee318feb0fd0 SHA512 7aa3c513c6702de0e099865f787858de4c9c65cfe95af61fd0204ff6df64e7359474b4067b4672546936beae6c8c512dd9c75f555d7075c94819e81143c21ce9
DIST humanize-3.9.0.tar.gz 64229 BLAKE2B 09aeec6a92c8e2e104032d4c61f054785ff58ce2dda68c4f3acffb17c7fa4e262b28a24b7c06d33671ea18d2eb05c9bcc0a82d5491e60afa161ebc0041945bf2 SHA512 75aa8f9f6b07d4b65e5589c3f337a92ee17769ab8da6608147b0f1ec3965b95788dd90cf0d0cae1b7c9be689b44910029ee72e2eba39a60c9926b67726c74353
diff --git a/dev-python/humanize/humanize-3.11.0.ebuild b/dev-python/humanize/humanize-3.11.0.ebuild
new file mode 100644
index 000000000000..ce3c080a882b
--- /dev/null
+++ b/dev-python/humanize/humanize-3.11.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest