summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-28 13:28:41 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-28 14:06:40 -0400
commit12436d4d974dc5f6de69cfb533c52fb0f426af0e (patch)
treebcd9792a8a9e79cb45a7a8d05cbf3078c5caa8c3
parentapp-crypt/gnupg: Revision bump to 2.1.14-r1 (diff)
downloadgentoo-12436d4d974dc5f6de69cfb533c52fb0f426af0e.tar.gz
gentoo-12436d4d974dc5f6de69cfb533c52fb0f426af0e.tar.bz2
gentoo-12436d4d974dc5f6de69cfb533c52fb0f426af0e.zip
dev-libs/libical: new version v2.0.0 with fix for bug 560572.
Gentoo-Bug: 560572 Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/libical/Manifest1
-rw-r--r--dev-libs/libical/files/fix-libdir-location.patch26
-rw-r--r--dev-libs/libical/libical-2.0.0.ebuild47
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/libical/Manifest b/dev-libs/libical/Manifest
index 8eb60fe32e22..bba6bafe115f 100644
--- a/dev-libs/libical/Manifest
+++ b/dev-libs/libical/Manifest
@@ -1 +1,2 @@
DIST libical-1.0.1.tar.gz 720618 SHA256 7d5f613454ec6c7d1bcfb441c919215be53292aa15cd1cb14249d1413d6c610c SHA512 efce88c73352fc34e9f7eda2234bdb593e917b33d1373cc6e6a21a72db1b14f2ed72976d6084dddcd8f07b08a15d5f04370bc825695d2fd40cc7b8488a7a977f WHIRLPOOL b9b4aa3fe0287a5394a8b23a1c3c810059554f6cce396b98f383df9950f984e0d18961086ecbdeb1c099ca6c63f68ceb2be08a9471817e0554ecc6e7fce06347
+DIST libical-2.0.0.tar.gz 699099 SHA256 20f4a98475052e1200d2691ba50b27969e4bedc6e50bffd5e2fa81f4ac90de9a SHA512 0b80f9aa40e0a485371b5949152c10d7fffb6e0dfe8c2aabc3c6e4e97ba0cdd465ae7093343245be60173bc7b24e80e919c0c0e199ff0bb2b14ed94af7087c4f WHIRLPOOL 64006dba88b8e3b691620b0f349ad06112c23903be977675a61a49dc2af3e90e9869993100261b0eb401964e7115133fcbf6048c68cf39607d3273eec8f6a158
diff --git a/dev-libs/libical/files/fix-libdir-location.patch b/dev-libs/libical/files/fix-libdir-location.patch
new file mode 100644
index 000000000000..53eb2040bc09
--- /dev/null
+++ b/dev-libs/libical/files/fix-libdir-location.patch
@@ -0,0 +1,26 @@
+This is a patch for Gentoo bug 560572, provided by Georgi Georgiev.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 773cf0c..e282ce4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -336,7 +336,7 @@ endif()
+ set(VERSION "${PROJECT_VERSION}")
+ set(prefix "${CMAKE_INSTALL_PREFIX}")
+ set(exec_prefix "\${prefix}")
+-set(libdir "\${exec_prefix}/lib")
++set(libdir "${LIB_INSTALL_DIR}")
+ set(includedir "\${prefix}/include")
+ set(PTHREAD_LIBS "${CMAKE_THREAD_LIBS_INIT}")
+
+diff --git a/libical.pc.in b/libical.pc.in
+index 7774dce..bf88476 100644
+--- a/libical.pc.in
++++ b/libical.pc.in
+@@ -8,5 +8,5 @@ iculib=@ICU_LIBRARIES@ @ICU_I18N_LIBRARIES@
+ Name: libical
+ Description: An implementation of basic iCAL protocols
+ Version: @VERSION@
+-Libs: -L${libdir} -lical -licalss -licalvcal ${threadslib} ${iculib}
++Libs: -lical -licalss -licalvcal ${threadslib} ${iculib}
+ Cflags: -I${includedir}
diff --git a/dev-libs/libical/libical-2.0.0.ebuild b/dev-libs/libical/libical-2.0.0.ebuild
new file mode 100644
index 000000000000..08ac5828f6a4
--- /dev/null
+++ b/dev-libs/libical/libical-2.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="An implementation of basic iCAL protocols"
+HOMEPAGE="https://github.com/libical/libical"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.0 LGPL-2.1 )"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples static-libs"
+
+# The GOBJECT_INTROSPECTION build is broken, and upstream has given up
+# on it at the moment (it's disabled in Travis). It will probably come
+# back in v2.0.1 or later.
+#RDEPEND="introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+DOCS=(
+ AUTHORS ReadMe.txt ReleaseNotes.txt TEST THANKS TODO
+ doc/{AddingOrModifyingComponents,UsingLibical}.txt
+)
+
+PATCHES=( "${FILESDIR}/fix-libdir-location.patch" )
+
+src_configure() {
+ # See above, introspection is disabled for v2.0.0 at least.
+ #local mycmakeargs=(
+ # -DGOBJECT_INTROSPECTION=$(usex introspection true false)
+ #)
+ use static-libs || mycmakeargs+=( -DSHARED_ONLY=ON )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use examples; then
+ rm examples/CMakeLists.txt || die
+ dodoc -r examples
+ fi
+}