summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2016-06-14 02:49:45 -0700
committerDaniel Campbell <zlg@gentoo.org>2016-06-14 02:49:45 -0700
commit125534a046099a8f5ef374c552f17897cf87c2fe (patch)
tree5cf1a678a1c0e385d22762076aacd85425f6d6b2
parentapp-text/pelican: Add myself as co-maintainer (diff)
downloadgentoo-125534a046099a8f5ef374c552f17897cf87c2fe.tar.gz
gentoo-125534a046099a8f5ef374c552f17897cf87c2fe.tar.bz2
gentoo-125534a046099a8f5ef374c552f17897cf87c2fe.zip
app-text/pelican: Add live ebuild
Add live ebuild, resolving bug 584280 Gentoo-Bug: 584280 Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=584280 Package-Manager: portage-2.3.0_rc1
-rw-r--r--app-text/pelican/pelican-9999.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-9999.ebuild
new file mode 100644
index 000000000000..d89aee9b53dc
--- /dev/null
+++ b/app-text/pelican/pelican-9999.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="http://blog.getpelican.com/ https://pypi.python.org/pypi/pelican"
+EGIT_REPO_URI="https://github.com/getpelican/pelican.git"
+EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples markdown test"
+# Tests fail for this release but are fixed upstream
+RESTRICT="test"
+
+DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ )"
+RDEPEND=""
+
+DOCS=( README.rst )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}