summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-31 16:46:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-31 17:21:22 +0200
commit126a90d2cc7e786fcf8e67a0b306c2318ca19feb (patch)
tree35f5ad09e9e68cff2b5002985a240136993570fe
parentdev-ros/actionlib: Remove old (diff)
downloadgentoo-126a90d2cc7e786fcf8e67a0b306c2318ca19feb.tar.gz
gentoo-126a90d2cc7e786fcf8e67a0b306c2318ca19feb.tar.bz2
gentoo-126a90d2cc7e786fcf8e67a0b306c2318ca19feb.zip
dev-ros/actionlib: bump to 1.11.14
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.11.14.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
index dfc6aed24a4e..6e83a8057229 100644
--- a/dev-ros/actionlib/Manifest
+++ b/dev-ros/actionlib/Manifest
@@ -1 +1,2 @@
DIST actionlib-1.11.13.tar.gz 98518 BLAKE2B 918c541f3a6192ee9b89e4b2759651e027d447acc305aaf9bdeabb9587a527b6bd924eb812314c8c83baec3b6829ca0b5d126550ea70acc5d2739f7cd83e065d SHA512 273499a0a5b1c9b40147ba0bba61b44a2530c0a16d757a51f6b6211c95790e18ffe2c397582a429de84a639209779c2641a3013f71f75a2fd76d422115033601
+DIST actionlib-1.11.14.tar.gz 98789 BLAKE2B fb4f7afbc2836f43ccfbb5d477a7e54ec4feb13244a797a057922b02cb97886052b2b6b2f2cb3cdf0ecb1b0c7dd09a24768ad9bc459498e0606ba534a82598c7 SHA512 147fc8642e8d46cf6dc353b4f8850c2682204a6f256a7e0a065db5adb67b72c54e2f40ff4cabbec2fab6d1a1b0c82ff0abbea571ae4202774892c3dae01ad8bd
diff --git a/dev-ros/actionlib/actionlib-1.11.14.ebuild b/dev-ros/actionlib/actionlib-1.11.14.ebuild
new file mode 100644
index 000000000000..72617b6f8b23
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+"