summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-01 14:35:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-01 19:34:17 +0200
commit127dd59ae62037ba8e151fef043a41cef32621a4 (patch)
treeb73dcce481ea19057ae29650ad5b6f3e9f8eead6
parentdev-lang/python: bump to 3.6.5 (diff)
downloadgentoo-127dd59ae62037ba8e151fef043a41cef32621a4.tar.gz
gentoo-127dd59ae62037ba8e151fef043a41cef32621a4.tar.bz2
gentoo-127dd59ae62037ba8e151fef043a41cef32621a4.zip
kde-misc/skanlite: 2.1.0 version bump
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--kde-misc/skanlite/Manifest1
-rw-r--r--kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch100
-rw-r--r--kde-misc/skanlite/skanlite-2.1.0.ebuild36
3 files changed, 137 insertions, 0 deletions
diff --git a/kde-misc/skanlite/Manifest b/kde-misc/skanlite/Manifest
index a4cb090a97ce..8ce37d19c564 100644
--- a/kde-misc/skanlite/Manifest
+++ b/kde-misc/skanlite/Manifest
@@ -1 +1,2 @@
DIST skanlite-2.0.1.tar.xz 2139624 BLAKE2B f6959650e6e59899e24f20214b2e94b0f4c004982e2ff961384c4a07e13305c6f839f679759db088c16ab879b499eb700edb5f7d8d65056ddd155c3a55f5365b SHA512 2dc29f3aeca32a7afb515ae9349fab7ef635de731718b53ceaf532cbd3860fbb07bd936fd2988b6dddb74109775e22752ffd05a0a3d0218b9c8ae393af52b14e
+DIST skanlite-2.1.0.tar.xz 1121468 BLAKE2B 8fd9bc7018e812203023a7e2906eb724e01baca70dbcccc08633f49e08de687738390a87d5c27526c084601d76f3cf272998818ad102d3dcd47518fab2fa47f6 SHA512 b346998f37def6b99c2feba7b323dbcb299c2bb0553598f83a30f8e7a04af1deaf60e7f5c70c4b663e0aecf95e7ee03252a15ef61745e6bc7d1c5a9d617aec00
diff --git a/kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch b/kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch
new file mode 100644
index 000000000000..fe5600c8c9a4
--- /dev/null
+++ b/kde-misc/skanlite/files/skanlite-2.1.0-cmake.patch
@@ -0,0 +1,100 @@
+From ac188879ebf7cab5631213305f289bec4ab25613 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 1 Apr 2018 13:36:48 +0200
+Subject: [PATCH 1/2] Cleanup CMakeLists.txt
+
+Cleanup duplicate find Qt5 and move all below #Dependencies block.
+Sort dependencies.
+KF5Sane is not an actual framework, so separate it from KF5 modules.
+---
+ CMakeLists.txt | 30 +++++++++++++-----------------
+ 1 file changed, 13 insertions(+), 17 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d05fb37..6aacfb9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,44 +17,40 @@ include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
+ include(KDECMakeSettings)
+ include(GenerateExportHeader)
+
+-find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets)
+-
+ # be not so strict with the poor developer who just wants to use strings
+ remove_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+ remove_definitions(-DQT_NO_CAST_FROM_BYTEARRAY)
+
+-set(KF5_VERSION "5.1.0")
++set(REQUIRED_QT_VERSION "5.2.0")
++set(KF5_MIN_VERSION "5.1.0")
+
+ ecm_setup_version(
+- ${KF5_VERSION}
++ ${KF5_MIN_VERSION}
+ VARIABLE_PREFIX SKANLITE
+ VERSION_HEADER "${CMAKE_CURRENT_BINARY_DIR}/skanlite_version.h"
+ PACKAGE_VERSION_FILE "${CMAKE_CURRENT_BINARY_DIR}/src/version.h.cmake"
+ )
+
++set(SKANLITE_VERSION_STRING "2.1.0")
++
++configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
++
+ # Dependencies
+-set(REQUIRED_QT_VERSION "5.2.0")
++find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets)
+
+-# Required Qt5 components to build this framework
+-find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core)
+ find_package(PNG REQUIRED)
+-
+ include_directories(${PNG_INCLUDE_DIRS})
+
+-set(SKANLITE_VERSION_STRING "2.1.0")
+-
+-configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/version.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/version.h)
+-
+-find_package(KF5 ${KF5_VERSION} REQUIRED
+- COMPONENTS # alias to find_package(KFGuiAddons ${KF5_VERSION} REQUIRED)
++find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+ CoreAddons # KAboutData
++ DocTools # yields kdoctools_create_handbook
+ I18n
+- XmlGui # KAboutApplicationDialog
+ KIO # contains the KIOWidgets which we use in target_link_libraries
+- DocTools # yields kdoctools_create_handbook
+- Sane # will find KF5Sane
++ XmlGui # KAboutApplicationDialog
+ )
+
++find_package(KF5Sane ${KF5_MIN_VERSION} REQUIRED)
++
+ add_definitions(-DQT_NO_URL_CAST_FROM_STRING)
+
+ # Subdirectories
+--
+2.16.3
+
+
+From 8bcc7e4fb701d2e95b8024df86830b9eeb6c97de Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 1 Apr 2018 13:50:34 +0200
+Subject: [PATCH 2/2] Make use of FeatureSummary
+
+---
+ CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6aacfb9..1736bff 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -58,3 +58,5 @@ add_subdirectory(src)
+ add_subdirectory(doc)
+ add_subdirectory(autotests)
+ add_subdirectory(tests)
++
++feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--
+2.16.3
+
diff --git a/kde-misc/skanlite/skanlite-2.1.0.ebuild b/kde-misc/skanlite/skanlite-2.1.0.ebuild
new file mode 100644
index 000000000000..c0883592a570
--- /dev/null
+++ b/kde-misc/skanlite/skanlite-2.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="KDE image scanning application"
+HOMEPAGE="https://www.kde.org/applications/graphics/skanlite"
+SRC_URI="mirror://kde/stable/${PN}/2.1/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2 GPL-3 ) handbook? ( FDL-1.2+ )"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep libksane)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ media-libs/libpng:0=
+"
+RDEPEND="${DEPEND}
+ !kde-misc/skanlite:4
+"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )