summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-19 16:24:55 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-19 17:16:29 +0100
commit1280dfcdbce73d31b95e612beb4f785527e9d2f3 (patch)
treed41b3ce5a37ca00dadaf6fd0771dedd03e8e4ac5
parentdev-cpp/gtksourceviewmm: Fix building with latest glibmm/libsigc++ (diff)
downloadgentoo-1280dfcdbce73d31b95e612beb4f785527e9d2f3.tar.gz
gentoo-1280dfcdbce73d31b95e612beb4f785527e9d2f3.tar.bz2
gentoo-1280dfcdbce73d31b95e612beb4f785527e9d2f3.zip
net-libs/net6: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
-rw-r--r--net-libs/net6/net6-1.3.14-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/net6/net6-1.3.14-r1.ebuild b/net-libs/net6/net6-1.3.14-r1.ebuild
new file mode 100644
index 000000000000..0b7fb4d22df1
--- /dev/null
+++ b/net-libs/net6/net6-1.3.14-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic multilib
+
+DESCRIPTION="Network access framework for IPv4/IPv6 written in C++"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="nls static-libs"
+
+RDEPEND="dev-libs/libsigc++:2
+ >=net-libs/gnutls-1.2.10"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib${PN}.la
+}
+
+pkg_postinst() {
+ elog "Please note that because of the use of C++ templates"
+ elog "Gobby 0.4 has to be recompiled against the new ${PN}"
+ elog "to pick up the changes."
+}