summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2016-03-09 21:30:45 +0900
committerAaron Bauman <bman@gentoo.org>2016-03-09 21:30:45 +0900
commit128249b3ddc62cbd4dadf2825c0b84411f69954a (patch)
tree1482338b1ffbaa9ed04f5b504efc3acd6a733a97
parentsys-devel/{clang,llvm}: Bump to final 3.8.0 (diff)
downloadgentoo-128249b3ddc62cbd4dadf2825c0b84411f69954a.tar.gz
gentoo-128249b3ddc62cbd4dadf2825c0b84411f69954a.tar.bz2
gentoo-128249b3ddc62cbd4dadf2825c0b84411f69954a.zip
net-misc/gns3-gui: revision to drop PyQt4 support and add additional PyQt5 USE. Thanks to Sebastian on bug 576798.
-rw-r--r--net-misc/gns3-gui/gns3-gui-1.4.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-misc/gns3-gui/gns3-gui-1.4.4-r1.ebuild b/net-misc/gns3-gui/gns3-gui-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..c561e4ee5196
--- /dev/null
+++ b/net-misc/gns3-gui/gns3-gui-1.4.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Graphical Network Simulator"
+HOMEPAGE="http://www.gns3.net/"
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+#net-misc/gns3-server version should always match gns3-gui version
+
+RDEPEND="
+ >=dev-python/libcloud-0.15.1[${PYTHON_USEDEP}]
+ >=dev-python/ws4py-0.3.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.15.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
+ >=net-misc/gns3-converter-1.3.0[${PYTHON_USEDEP}]
+ =net-misc/gns3-server-$PV[${PYTHON_USEDEP}]
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-python/PyQt5[gui,network,svg,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_configure() {
+ # temporary fix until upstream releases 1.4.5 with proper setup.py
+ sed -i -e 's/gns3-net-converter/gns3-converter/' setup.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doicon "${WORKDIR}/${P}/resources/images/gns3.ico"
+ make_desktop_entry "gns3" "GNS3" "/usr/share/pixmaps/gns3.ico" "Utility"
+}