summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-16 18:09:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-16 18:11:14 +0200
commit130b9cca5299f1635e5802c16dca604aef545c79 (patch)
treee2031fceb9097d38e1a5d23f70d4e8850e043f21
parentapp-portage/gpyutils: Remove the live ebuild (diff)
downloadgentoo-130b9cca5299f1635e5802c16dca604aef545c79.tar.gz
gentoo-130b9cca5299f1635e5802c16dca604aef545c79.tar.bz2
gentoo-130b9cca5299f1635e5802c16dca604aef545c79.zip
app-portage/gpyutils: Bump to 0.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/gpyutils/Manifest1
-rw-r--r--app-portage/gpyutils/gpyutils-0.6.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gpyutils/Manifest b/app-portage/gpyutils/Manifest
index c22e9d08ffbe..e7218fed78d9 100644
--- a/app-portage/gpyutils/Manifest
+++ b/app-portage/gpyutils/Manifest
@@ -1 +1,2 @@
DIST gpyutils-0.6.1.tar.gz 23914 BLAKE2B 1e799ce33a949037b68262cb7a6ca5fd99b4ca4ec74c3044bfb31ea08b59906a21f6c96cdf99330f6af16d68be6ee7ab49c3cf05979691899abaacc9d62032eb SHA512 74d984e496ccfa7124cfefd9f8f79d5fab4bb4dbf5e61f4400b39367dd54e23b871f286eef28007a5c255b862533a34948449bbf7aed55cf8fe315e76ac876ea
+DIST gpyutils-0.6.2.tar.gz 23585 BLAKE2B 6458569d42b8095e6b355ca4e3ce7173ccddef6c3e01a103d997d3e395515ad145c562171bc73711d994e4503b9fef99534ec608985c5f8f4482a1bbe3172e47 SHA512 fcd8312b7752c1a4de46cd9655300097962270c2ca07572eda4e9240c9a32d4a58d200659d2a26c38fb1389ec57cac6beb1b40a7d0520d6505db42e6fbe593dc
diff --git a/app-portage/gpyutils/gpyutils-0.6.2.ebuild b/app-portage/gpyutils/gpyutils-0.6.2.ebuild
new file mode 100644
index 000000000000..8b95aeb92dbf
--- /dev/null
+++ b/app-portage/gpyutils/gpyutils-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Utitilies for maintaining Python packages"
+HOMEPAGE="https://github.com/mgorny/gpyutils/"
+SRC_URI="
+ https://github.com/mgorny/gpyutils/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-portage/gentoopm-0.3.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --doctest-modules
+}