summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-04-25 18:55:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-04-25 18:55:49 +1000
commit1340b37c064df2043a86584c8d3b9ac68ce702db (patch)
treec05fd0c7e0261a5aa2c484c48ee4334d2df3c3ed
parentnet-p2p/qbittorrent: remove 3.3.7 (diff)
downloadgentoo-1340b37c064df2043a86584c8d3b9ac68ce702db.tar.gz
gentoo-1340b37c064df2043a86584c8d3b9ac68ce702db.tar.bz2
gentoo-1340b37c064df2043a86584c8d3b9ac68ce702db.zip
net-p2p/qbittorrent: version bump 3.3.12
Also backports a patch from upstream solving build failure with cmake-3.8. Gentoo-bug: 615470 Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.12.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 2abd6d26cf0b..27fa3834c930 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,2 +1,4 @@
DIST qbittorrent-3.3.10.tar.xz 2959380 SHA256 2c657ceacdc84033da044a0a9ecba7e0fdb35858324dc097546f989166f1a8d2 SHA512 4f4e7071fa6db75ed2b5fbf5f17d5a9634aa5f2ed9fbcec52e6a0112967f5832e998384c7ff4962b1e00a0f847fa5d39bcdba36f997b5b895c7688e0dd247516 WHIRLPOOL 950b49d7a15aa7cf16dfe2bbfba72959e91f21f85ba589ce85be370b8b21c03fb389d404ed46ad2c802e3a57660094fe644b20df9bc3a0714cb5d9ea965e1b97
DIST qbittorrent-3.3.11.tar.xz 2986312 SHA256 4892ac5ed4bde2ed325fb67456698e703bb933b9eb1d146598259f4e2154a760 SHA512 1f7d4a40b7f966e710d4cbed721074d53b0478ed1970932dee32b73ea210251cbd3807912e9c9a00371fa41f5c947c59443bbda4925b022fbe88fc23b3f225c5 WHIRLPOOL 5fb2e0456d81b104e5545329a301040c81a18b25798e831ab8f780f8ee19d09c12f5315d5581243e141f7a00eb938ab449927871c70a4bf5e9c2e6dd71d4aca3
+DIST qbittorrent-3.3.12-cmake-3.8.patch.gz 18330 SHA256 8172d04af3621ed0859ff541ae6c6e73f469125e0b7defd591191ab8c233e658 SHA512 e5aa6aa32f12c47a28658b2382faca88b64be1c198c69ad88f4fcd9f18d2db7a4e71c170dffd142b5af0184105b04dc2409417761db8859f622d42af7d25b060 WHIRLPOOL a68723a52858aed3e0474e0ccc3bcde7a451b388c8cd30ea5548f53e950902e234cb7e9cc32a86c75e367c4cad33a40beab52619de0a1f27442b89a10c25e67f
+DIST qbittorrent-3.3.12.tar.xz 2989604 SHA256 56528c47f09b316ecf682e3896157c76c18898ef996728b0c5186e05a711466f SHA512 537ded71c75b3ab3fe014d77b5c4f8069ebb7a1aa94b5190b16e9ee910bfb70d462e5a3a536ba9222a97d8cceac00af0d33a92b7414b17724694d364fc2374df WHIRLPOOL 9f3b7cb85885691ea747b2569690aa3d1189798be6000e9ec2c8af65ccd86010be877af10b540422233f5b8c253bf221fad0fea6fdc9a0b5dcbc3cedf50613bd
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.12.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.12.ebuild
new file mode 100644
index 000000000000..5f905e2ad776
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ MY_P=${P/_}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz
+ https://dev.gentoo.org/~kensington/distfiles/${P}-cmake-3.8.patch.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+PATCHES=( "${WORKDIR}"/${P}-cmake-3.8.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT5=ON
+ -DSYSTEM_QTSINGLEAPPLICATION=ON
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex X)
+ -DWEBUI=$(usex webui)
+ )
+ cmake-utils_src_configure
+}