summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-23 15:12:03 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-23 15:13:26 +0200
commit14125711c8a870b5cd5f59df28946c8b742640c7 (patch)
tree74e45b349ceeb12431dc65f5b922a3c02e29650e
parentdev-python/vpython: bump to 7.4.6 (diff)
downloadgentoo-14125711c8a870b5cd5f59df28946c8b742640c7.tar.gz
gentoo-14125711c8a870b5cd5f59df28946c8b742640c7.tar.bz2
gentoo-14125711c8a870b5cd5f59df28946c8b742640c7.zip
net-analyzer/pypacker: Version 4.6.
Fixes: https://bugs.gentoo.org/663258 Package-Manager: Portage-2.3.49, Repoman-2.3.11
-rw-r--r--net-analyzer/pypacker/Manifest1
-rw-r--r--net-analyzer/pypacker/pypacker-4.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
index 4a42e57194ad..8ef31bcff028 100644
--- a/net-analyzer/pypacker/Manifest
+++ b/net-analyzer/pypacker/Manifest
@@ -1 +1,2 @@
DIST pypacker-2.9.tar.gz 276080 BLAKE2B 3bab4b4c7879fea10accbd3fb2bcb4a8e27096a29240f6b8e4e06c3486ee0cb2b8fa1e83674dee759fafc85c2e182cb75e836c00dfe28c83c0bb2cecaed758cd SHA512 b7ca61948a55a37661fa402ebc5a9c2be456e8df14d1ee091a50ccd1362c7a7fa9224e1ae2b8ee8057f302ee9e0c61c06d07b627dde92947f8d22158ef3623b8
+DIST pypacker-4.6.tar.gz 592362 BLAKE2B 41fc63f1fc40ab1cfc007db9dfc6d18cedb51cc8525dc2b467bc03babe03c49f9f0771b8146aacf80f74c511619da85e1f7d56667bcda350710e4c0bafb89351 SHA512 c55205b35f653903149517aad0e2d055745edd6c1a28b1b49aeaa435ca327693b20ed6f851011fa80df1fcc5281ac8b92fbffa3b1381cb3d4507ef7d45d49545
diff --git a/net-analyzer/pypacker/pypacker-4.6.ebuild b/net-analyzer/pypacker/pypacker-4.6.ebuild
new file mode 100644
index 000000000000..03473c1ed8f2
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-4.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="${HOMEPAGE}/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${PYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}