summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-06-11 23:30:05 +0200
committerMichał Górny <mgorny@gentoo.org>2016-06-11 23:31:03 +0200
commit1426be7f18ab854dc1b86bdbe64a9c0a02579db9 (patch)
tree7662defd246eb10b6380e6fcbb48289973369cc6
parentdev-ruby/travis: fix deps (diff)
downloadgentoo-1426be7f18ab854dc1b86bdbe64a9c0a02579db9.tar.gz
gentoo-1426be7f18ab854dc1b86bdbe64a9c0a02579db9.tar.bz2
gentoo-1426be7f18ab854dc1b86bdbe64a9c0a02579db9.zip
xfce-base/libxfce4ui: Bump to 4.13.0
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.13.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index ec24790717f2..2a3b6fbd929a 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.10.0.tar.bz2 545486 SHA256 a2b9fa288ccb5f16fa13264e507ba3f7b8da0176da259a11239f21538c0ea3e2 SHA512 18de63f3198480730460d93bbe10c17bb64cd115cfc3878be3e1c800e209f5bf1a7441b4661e7c09fc6109b76791c952a7792eac0c2b846827a89e3ddfb2292e WHIRLPOOL 80e2b724805b3bfd120c4e8f6e9fff1ae9a1829b4033e7370806ec4ad95ed79410d8c67b0d57b0095c1bac3ed4d0843fdeddcb86f574e83873392b07b52834a2
DIST libxfce4ui-4.12.1.tar.bz2 665624 SHA256 3d619811bfbe7478bb984c16543d980cadd08586365a7bc25e59e3ca6384ff43 SHA512 9d132a81bc3385b6582c2d97ed7a1fc0ea289d9098cc4c3a7fb523329eb6afb18716bcf98a5832c4484794eb7a2be4242fa2e71083cd5e55cb19e3b8003458a8 WHIRLPOOL bfc23f795755af6dc7a0ea947dfc931c3dc8eaa64d73303361d0be8cad77d5a9206d349551995de8a291281270564ed54f947f4c56285f7bc8ae91dfbfdd538d
+DIST libxfce4ui-4.13.0.tar.bz2 688646 SHA256 22f0b66a33945f347952249589f71618418f1e47ca847850eb0ee1bdb0c353d4 SHA512 342c4fb09b3f13e066b994c54cd557a65c116566b8201217cb663851ba387932cdd4ebf2274f32bdc97a98b3a2bd1b59de75ef6cc4c6f5d0e5f1910b7eca591e WHIRLPOOL 37d9d68af580482186e5f1bd078b72b48339ee032b85e38ea944b2a08e80deead2887fbee9f30b15251214bb0aae7cc92857f2559db116767c96f630ad5b7d80
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.13.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.13.0.ebuild
new file mode 100644
index 000000000000..e1a0801e9813
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.13.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widget and session management libraries for Xfce"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade +gtk3 startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ >=x11-libs/gtk+-2.24:2=
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10= )
+ gtk3? ( >=x11-libs/gtk+-3.2:3= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable gtk3)
+ $(xfconf_use_debug)
+ # requires deprecated glade:3 (gladeui-1.0), bug #551296
+ --disable-gladeui
+ # this one's for :3.10
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}